aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-04-17 07:01:43 +0800
committeradamw <adamw@FreeBSD.org>2016-04-17 07:01:43 +0800
commit0af20aae9190e41a3a95931476c83fcc1f219819 (patch)
treef4c1f4deb2208d6b6100611412a3752c35791beb /mail
parentf5508d1f13b64f85b7573dbe8e5c6e0ee7d8bd16 (diff)
downloadfreebsd-ports-gnome-0af20aae9190e41a3a95931476c83fcc1f219819.tar.gz
freebsd-ports-gnome-0af20aae9190e41a3a95931476c83fcc1f219819.tar.zst
freebsd-ports-gnome-0af20aae9190e41a3a95931476c83fcc1f219819.zip
Add clamav and dkim filters for opensmtpd-extras.
While here, improve the filter-spamassassin port to show the correct port and host. I'm done adding opensmtpd-extras now.
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile2
-rw-r--r--mail/opensmtpd-extras-filter-clamav/Makefile34
-rw-r--r--mail/opensmtpd-extras-filter-dkim/Makefile17
-rw-r--r--mail/opensmtpd-extras-filter-spamassassin/Makefile4
-rw-r--r--mail/opensmtpd-extras/Makefile8
5 files changed, 63 insertions, 2 deletions
diff --git a/mail/Makefile b/mail/Makefile
index fbf5249886b8..5a1020254e3c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -293,6 +293,8 @@
SUBDIR += opensmtpd
SUBDIR += opensmtpd-devel
SUBDIR += opensmtpd-extras
+ SUBDIR += opensmtpd-extras-filter-clamav
+ SUBDIR += opensmtpd-extras-filter-dkim
SUBDIR += opensmtpd-extras-filter-dnsbl
SUBDIR += opensmtpd-extras-filter-pause
SUBDIR += opensmtpd-extras-filter-regex
diff --git a/mail/opensmtpd-extras-filter-clamav/Makefile b/mail/opensmtpd-extras-filter-clamav/Makefile
new file mode 100644
index 000000000000..5fbcde3ffd85
--- /dev/null
+++ b/mail/opensmtpd-extras-filter-clamav/Makefile
@@ -0,0 +1,34 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -filter-clamav
+
+COMMENT= Check messages with ClamAV in OpenSMTPD
+MAINTAINER= adamw@FreeBSD.org
+
+RUN_DEPENDS= clamscan:security/clamav
+
+PLIST_FILES= libexec/opensmtpd/filter-clamav \
+ man/man8/filter-clamav.8.gz
+
+CONFIGURE_ARGS+= --with-filter-clamav
+
+MASTERDIR= ${.CURDIR}/../opensmtpd-extras
+SLAVE_PORT= yes
+
+# These have to be set at compile-time. These are the
+# defaults for ClamAV.
+FILTER_CLAMAV_HOST?= 127.0.0.1
+FILTER_CLAMAV_PORT?= 3310
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/^#define CLAMAV_HOST/s/127.0.0.1/${FILTER_CLAMAV_HOST}/' \
+ -e '/^#define CLAMAV_PORT/s/783/${FILTER_CLAMAV_PORT}/' \
+ ${WRKSRC}/extras/wip/filters/filter-clamav/filter_clamav.c
+ @${REINPLACE_CMD} \
+ -e 's/127.0.0.1/${FILTER_CLAMAV_HOST}/' \
+ -e 's/783/${FILTER_CLAMAV_PORT}/' \
+ ${WRKSRC}/extras/wip/filters/filter-clamav/filter-clamav.8
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/opensmtpd-extras-filter-dkim/Makefile b/mail/opensmtpd-extras-filter-dkim/Makefile
new file mode 100644
index 000000000000..be1142bd3be4
--- /dev/null
+++ b/mail/opensmtpd-extras-filter-dkim/Makefile
@@ -0,0 +1,17 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -filter-dkim
+
+COMMENT= DKIM-signing filter for OpenSMTPD
+MAINTAINER= adamw@FreeBSD.org
+
+PLIST_FILES= libexec/opensmtpd/filter-dkim-signer \
+ man/man8/filter-dkim-signer.8.gz
+
+CONFIGURE_ARGS+= --with-filter-dkim-signer
+
+MASTERDIR= ${.CURDIR}/../opensmtpd-extras
+SLAVE_PORT= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/opensmtpd-extras-filter-spamassassin/Makefile b/mail/opensmtpd-extras-filter-spamassassin/Makefile
index aec0e82b1bcb..de1e2b5f9d25 100644
--- a/mail/opensmtpd-extras-filter-spamassassin/Makefile
+++ b/mail/opensmtpd-extras-filter-spamassassin/Makefile
@@ -24,5 +24,9 @@ post-patch:
-e '/^#define SPAMASSASSIN_HOST/s/127.0.0.1/${FILTER_SPAMASSASSIN_HOST}/' \
-e '/^#define SPAMASSASSIN_PORT/s/783/${FILTER_SPAMASSASSIN_PORT}/' \
${WRKSRC}/extras/wip/filters/filter-spamassassin/filter_spamassassin.c
+ @${REINPLACE_CMD} \
+ -e 's/127.0.0.1/${FILTER_SPAMASSASSIN_HOST}/' \
+ -e 's/783/${FILTER_SPAMASSASSIN_PORT}/' \
+ ${WRKSRC}/extras/wip/filters/filter-spamassassin/filter-spamassassin.8
.include "${MASTERDIR}/Makefile"
diff --git a/mail/opensmtpd-extras/Makefile b/mail/opensmtpd-extras/Makefile
index 27f3aada29f1..18505a9232d5 100644
--- a/mail/opensmtpd-extras/Makefile
+++ b/mail/opensmtpd-extras/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opensmtpd-extras
PORTVERSION= 201602042118
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES+= mail
MASTER_SITES= http://www.opensmtpd.org/archives/
@@ -22,11 +22,13 @@ GNU_CONFIGURE= yes
.if empty(SLAVE_PORT)
OPTIONS_GROUP= FILTER TABLE
-OPTIONS_GROUP_FILTER= DNSBL PAUSE REGEX SPAMASSASSIN
+OPTIONS_GROUP_FILTER= CLAMAV DKIM DNSBL PAUSE REGEX SPAMASSASSIN
OPTIONS_GROUP_TABLE= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
OPTIONS_DEFAULT= ${OPTIONS_GROUP_FILTER} ${OPTIONS_GROUP_TABLE}
# Filters
+CLAMAV_DESC= Check messages with ClamAV
+DKIM_DESC= Sign messages with DKIM
DNSBL_DESC= Check messages against DNSBLs
PAUSE_DESC= Pause incoming messages to reduce spam
SPAMASSASSIN_DESC= Check messages with SpamAssassin
@@ -44,6 +46,8 @@ NO_ARCH= yes
#
# Filters
#
+CLAMAV_RUN_DEPENDS= ${INSTALL_DIR}/filter-clamav:mail/opensmtpd-extras-filter-clamav
+DKIM_RUN_DEPENDS= ${INSTALL_DIR}/filter-dkim-signer:mail/opensmtpd-extras-filter-dkim
DNSBL_RUN_DEPENDS= ${INSTALL_DIR}/filter-dnsbl:mail/opensmtpd-extras-filter-dnsbl
PAUSE_RUN_DEPENDS= ${INSTALL_DIR}/filter-pause:mail/opensmtpd-extras-filter-pause
REGEX_RUN_DEPENDS= ${INSTALL_DIR}/filter-regex:mail/opensmtpd-extras-filter-regex