aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2006-07-06 14:12:21 +0800
committerdelphij <delphij@FreeBSD.org>2006-07-06 14:12:21 +0800
commit1614b006948f362a4e4e2d73a5f049fd49f3c839 (patch)
treeb7ff6ec7d957467121f1831db0b2b977089ec50d /mail
parente253f1dd9b7f8259a38e8ba46d28761a25bb4855 (diff)
downloadfreebsd-ports-gnome-1614b006948f362a4e4e2d73a5f049fd49f3c839.tar.gz
freebsd-ports-gnome-1614b006948f362a4e4e2d73a5f049fd49f3c839.tar.zst
freebsd-ports-gnome-1614b006948f362a4e4e2d73a5f049fd49f3c839.zip
+ Add rc.d script: mps
* Pet portlint(1)
Diffstat (limited to 'mail')
-rw-r--r--mail/missey/Makefile7
-rw-r--r--mail/missey/files/mps.sh.in26
2 files changed, 31 insertions, 2 deletions
diff --git a/mail/missey/Makefile b/mail/missey/Makefile
index e982a7c738b5..4a76e64ae369 100644
--- a/mail/missey/Makefile
+++ b/mail/missey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= missey
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.dengh.com/missey/
DISTNAME= mps.${PORTVERSION}
@@ -19,12 +20,14 @@ USE_BZIP2= yes
WRKSRC= ${WRKDIR}/mps/src
MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" \
- PREFIX="$(PREFIX)" INSTALL_PROGRAM="$(INSTALL_PROGRAM)" \
- INSTALL_DATA="$(INSTALL_DATA)" MKDIR="$(MKDIR)" WRKSRC="$(WRKSRC)"
+ PREFIX="${PREFIX}" INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_DATA="${INSTALL_DATA}" MKDIR="${MKDIR}" WRKSRC="${WRKSRC}"
PLIST_FILES= sbin/bent sbin/mps etc/mps/pop3d.conf-dist
PLIST_DIRS= etc/mps
+USE_RC_SUBR= mps.sh
+
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
diff --git a/mail/missey/files/mps.sh.in b/mail/missey/files/mps.sh.in
new file mode 100644
index 000000000000..2bc785013751
--- /dev/null
+++ b/mail/missey/files/mps.sh.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: mps
+# REQUIRE: LOGIN
+
+#
+# Add the following line to /etc/rc.conf to enable mps:
+# mps_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable Missey POP3 Server.
+#
+
+. %%RC_SUBR%%
+
+name="mps"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${mps_enable="NO"}
+
+command="%%PREFIX%%/sbin/mps"
+
+run_rc_command "$1"