aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2018-01-30 04:59:18 +0800
committerzeising <zeising@FreeBSD.org>2018-01-30 04:59:18 +0800
commit65800882c0182a741d74f59b3642c53aabb4ddbc (patch)
tree81724dc081726050ee90bc21958ebc0adf16fbd0 /mail
parentc8f205ec30cfc370c54d41b71dd6b3b58239275a (diff)
downloadfreebsd-ports-gnome-65800882c0182a741d74f59b3642c53aabb4ddbc.tar.gz
freebsd-ports-gnome-65800882c0182a741d74f59b3642c53aabb4ddbc.tar.zst
freebsd-ports-gnome-65800882c0182a741d74f59b3642c53aabb4ddbc.zip
Add patch and fix CVE-2017-15132
Add upstream patch to fix CVE-2017-15132, memory leak in the log in process that can cause memory exhaustion. PR: 225446 Submitted by: Vladimir Krstulja Approved by: adamw (maintainer), swills (ports-secteam) MFH: 2018Q1 Security: 92b8b284-a3a2-41b1-956c-f9cf8b74f500
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/files/patch-src_lib-auth_auth-client-request.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 912c52ae9efd..e2b44792bce1 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -13,7 +13,7 @@
PORTNAME= dovecot
PORTVERSION= 2.2.33.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.2/
diff --git a/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c b/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
new file mode 100644
index 000000000000..7cc94b62f148
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
@@ -0,0 +1,10 @@
+--- src/lib-auth/auth-client-request.c.orig 2017-10-05 17:10:44 UTC
++++ src/lib-auth/auth-client-request.c
+@@ -180,6 +180,7 @@ void auth_client_request_abort(struct auth_client_requ
+
+ auth_client_send_cancel(request->conn->client, request->id);
+ call_callback(request, AUTH_REQUEST_STATUS_ABORT, NULL, NULL);
++ pool_unref(&request->pool);
+ }
+
+ unsigned int auth_client_request_get_id(struct auth_client_request *request)