aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-14 07:36:40 +0800
committerbapt <bapt@FreeBSD.org>2014-07-14 07:36:40 +0800
commit736ba1e7b3394f86195da6df293f1badc3dc06fd (patch)
treecaf481fc0fb12e9f5b4f7e105ea42f01f77c286a /mail
parent7244029e548a8568a25201a0e345fd4bc5e9ec5b (diff)
downloadfreebsd-ports-gnome-736ba1e7b3394f86195da6df293f1badc3dc06fd.tar.gz
freebsd-ports-gnome-736ba1e7b3394f86195da6df293f1badc3dc06fd.tar.zst
freebsd-ports-gnome-736ba1e7b3394f86195da6df293f1badc3dc06fd.zip
Modernize LIB_DEPENDS
With hat: portmgr
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter-tc/Makefile2
-rw-r--r--mail/courier/Makefile2
-rw-r--r--mail/evolution-mapi/Makefile2
-rw-r--r--mail/ftrack/Makefile2
-rw-r--r--mail/greylite/Makefile4
-rw-r--r--mail/milter-manager/Makefile2
-rw-r--r--mail/mu/Makefile4
-rw-r--r--mail/p3scan/Makefile2
-rw-r--r--mail/p5-Mail-OpenDKIM/Makefile2
-rw-r--r--mail/pecl-esmtp/Makefile2
-rw-r--r--mail/perdition/Makefile14
-rw-r--r--mail/pop3vscan/Makefile2
-rw-r--r--mail/qmail-dk/Makefile2
-rw-r--r--mail/softfail/Makefile2
-rw-r--r--mail/sqwebmail/Makefile2
-rw-r--r--mail/xf-spf/Makefile2
16 files changed, 24 insertions, 24 deletions
diff --git a/mail/bogofilter-tc/Makefile b/mail/bogofilter-tc/Makefile
index b8c3060b6328..e41dc5e03f49 100644
--- a/mail/bogofilter-tc/Makefile
+++ b/mail/bogofilter-tc/Makefile
@@ -9,7 +9,7 @@ PKGNAMESUFFIX= -tc
MAINTAINER= mandree@FreeBSD.org
# Blanket approval for changes by Zach Thompson (address above)
-LIB_DEPENDS= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
+LIB_DEPENDS= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
CONFLICTS_INSTALL= bogofilter-[0-9]* [a-z][a-z]-bogofilter-[1-9]* bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]*
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 95b05c62601c..dbefd8998ff5 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= bsd@dino.sk
COMMENT= Courier SMTP IMAP POP3 HTTP mail server suite
BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base \
${LOCALBASE}/share/sysconftool/sysconftool:${PORTSDIR}/devel/sysconftool \
${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support \
diff --git a/mail/evolution-mapi/Makefile b/mail/evolution-mapi/Makefile
index 74bb9a8d9495..90f8d3e99ea7 100644
--- a/mail/evolution-mapi/Makefile
+++ b/mail/evolution-mapi/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Evolution plugin to connect to Microsoft Exchange servers
BUILD_DEPENDS= ${PKGFILES}:${PORTSDIR}/mail/evolution
-LIB_DEPENDS= mapi.0:${PORTSDIR}/mail/libmapi
+LIB_DEPENDS= libmapi.so:${PORTSDIR}/mail/libmapi
RUN_DEPENDS= ${PKGFILES}:${PORTSDIR}/mail/evolution
PKGFILES= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin.pc
diff --git a/mail/ftrack/Makefile b/mail/ftrack/Makefile
index f37fd0a9ba65..ff62438328ab 100644
--- a/mail/ftrack/Makefile
+++ b/mail/ftrack/Makefile
@@ -15,7 +15,7 @@ COMMENT= FTN Messages tracker
BROKEN= Does not compile
-LIB_DEPENDS= smapi.2:${PORTSDIR}/news/husky-smapi
+LIB_DEPENDS= libsmapi.so:${PORTSDIR}/news/husky-smapi
USES= perl5 gmake zip
ALL_TARGET= ftrack
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
index 29fccab990d3..0a6987b55e92 100644
--- a/mail/greylite/Makefile
+++ b/mail/greylite/Makefile
@@ -31,12 +31,12 @@ NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
MAKE_ARGS+= WITH_GEOIP=yep
.endif
.if ${PORT_OPTIONS:MDNSBLENV}
-LIB_DEPENDS+= cares:${PORTSDIR}/dns/c-ares
+LIB_DEPENDS+= libcares.so:${PORTSDIR}/dns/c-ares
MAKE_ARGS+= WITH_DNSBLENV=yep
PLIST_SUB+= DNSBLENV=""
.else
diff --git a/mail/milter-manager/Makefile b/mail/milter-manager/Makefile
index d2bbde12b549..a9da4d49191b 100644
--- a/mail/milter-manager/Makefile
+++ b/mail/milter-manager/Makefile
@@ -13,7 +13,7 @@ LICENSE= AGPLv3 GFDL GPLv3 LGPL3
LICENSE_COMB= multi
BUILD_DEPENDS= rubygem-glib2>0:${PORTSDIR}/devel/rubygem-glib2
-LIB_DEPENDS= ev:${PORTSDIR}/devel/libev
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
RUN_DEPENDS= rubygem-glib2>0:${PORTSDIR}/devel/rubygem-glib2
USE_RC_SUBR= milter-manager
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
index 365a41762bff..8f8dc233a256 100644
--- a/mail/mu/Makefile
+++ b/mail/mu/Makefile
@@ -12,8 +12,8 @@ COMMENT= Mail searching frontend for Xapian
LICENSE= GPLv3
-LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core \
- gmime:${PORTSDIR}/mail/gmime24
+LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core \
+ libgmime.so:${PORTSDIR}/mail/gmime24
GNU_CONFIGURE= yes
USES= pkgconfig gmake
diff --git a/mail/p3scan/Makefile b/mail/p3scan/Makefile
index 84018284c7be..fac482513620 100644
--- a/mail/p3scan/Makefile
+++ b/mail/p3scan/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTNAME}-${PORTVERSIO
MAINTAINER= ports@FreeBSD.org
COMMENT= Transparent POP3-Proxy with virus-scanning capabilities
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
PLIST_FILES= etc/p3scan/p3scan.conf.sample etc/p3scan/p3scan.mail.sample \
sbin/p3scan
diff --git a/mail/p5-Mail-OpenDKIM/Makefile b/mail/p5-Mail-OpenDKIM/Makefile
index beef58c419ad..01c15477e345 100644
--- a/mail/p5-Mail-OpenDKIM/Makefile
+++ b/mail/p5-Mail-OpenDKIM/Makefile
@@ -14,7 +14,7 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= opendkim>=2.5.0:${PORTSDIR}/mail/opendkim
-LIB_DEPENDS= opendkim:${PORTSDIR}/mail/opendkim
+LIB_DEPENDS= libopendkim.so:${PORTSDIR}/mail/opendkim
RUN_DEPENDS= opendkim>=2.5.0:${PORTSDIR}/mail/opendkim \
p5-Error>=0:${PORTSDIR}/lang/p5-Error
diff --git a/mail/pecl-esmtp/Makefile b/mail/pecl-esmtp/Makefile
index 55eb618bb645..1c256b05b624 100644
--- a/mail/pecl-esmtp/Makefile
+++ b/mail/pecl-esmtp/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= PECL ESMTP client extension
-LIB_DEPENDS= esmtp:${PORTSDIR}/mail/libesmtp
+LIB_DEPENDS= libesmtp.so:${PORTSDIR}/mail/libesmtp
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index 6b563239cead..7a8cc1885865 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= http://horms.net/projects/perdition/download/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= POP3 & IMAP4 proxy that can map users to multiple backend servers
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
- vanessa_logger:${PORTSDIR}/devel/libvanessa_logger \
- vanessa_socket:${PORTSDIR}/devel/libvanessa_socket \
- vanessa_adt:${PORTSDIR}/devel/libvanessa_adt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt \
+ libvanessa_logger.so:${PORTSDIR}/devel/libvanessa_logger \
+ libvanessa_socket.so:${PORTSDIR}/devel/libvanessa_socket \
+ libvanessa_adt.so:${PORTSDIR}/devel/libvanessa_adt
MAN5= perditiondb.5
MAN8= perdition.8
@@ -65,7 +65,7 @@ PLIST_SUB+= POSIXREGEX="@comment "
.if ${PORT_OPTIONS:MDAEMON_MAP}
CONFIGURE_ARGS+= --enable-daemon-map
PLIST_SUB+= DAEMONMAP=""
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
.else
CONFIGURE_ARGS+= --disable-daemon-map
PLIST_SUB+= DAEMONMAP="@comment "
@@ -92,7 +92,7 @@ PLIST_SUB+= NIS="@comment "
.if ${PORT_OPTIONS:MGDBM}
CONFIGURE_ARGS+= --enable-gdbm
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
MAN1+= makegdbm.1
.else
@@ -134,7 +134,7 @@ PLIST_SUB+= LDAP="@comment "
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+= --enable-odbc
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
PLIST_SUB+= ODBC=""
MAN8+= perditiondb_odbc_makedb.8
.else
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
index 73f18afb7c96..8352b29054c5 100644
--- a/mail/pop3vscan/Makefile
+++ b/mail/pop3vscan/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= leeym@FreeBSD.org
COMMENT= Transparent POP3-Proxy with virus-scanning capabilities
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
USES= gmake
USE_GCC= yes
diff --git a/mail/qmail-dk/Makefile b/mail/qmail-dk/Makefile
index b150be618bf3..f86fd4f267ff 100644
--- a/mail/qmail-dk/Makefile
+++ b/mail/qmail-dk/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= qmail
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= DomainKeys implementation for qmail
-LIB_DEPENDS+= domainkeys:${PORTSDIR}/mail/libdomainkeys
+LIB_DEPENDS+= libdomainkeys.so:${PORTSDIR}/mail/libdomainkeys
PATCH_SITES= ${MASTER_SITE_QMAIL}
PATCHFILES= qmail-1.03-dk-0.54.patch
diff --git a/mail/softfail/Makefile b/mail/softfail/Makefile
index 8b63205faed0..16c6d7d6a82d 100644
--- a/mail/softfail/Makefile
+++ b/mail/softfail/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}_fbsdbrasil-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Enhanced greylisting system for qmail w/ SMTPEXTFORK patch
-LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
+LIB_DEPENDS+= libspf2.so:${PORTSDIR}/mail/libspf2
SUB_FILES= pkg-message
SUB_LIST= QMAIL_PREFIX=${QMAIL_PREFIX}
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index c51a89875a40..0e9ef15bc5fe 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -11,7 +11,7 @@ COMMENT= CGI Webmail client for Maildirs
BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
CFLAGS:= -I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS:S/^[:space:]*//}
CXXFLAGS:= -I${LOCALBASE}/include ${CXXFLAGS:S/^[:space:]*//}
diff --git a/mail/xf-spf/Makefile b/mail/xf-spf/Makefile
index 60d423a81be9..e1823af14752 100644
--- a/mail/xf-spf/Makefile
+++ b/mail/xf-spf/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www6.freebsdbrasil.com.br/~eksffa/l/dev/qmail-smtpextfork/
MAINTAINER= ports@FreeBSD.org
COMMENT= SPF checker for Qmail's SMTPEXTFORK patch
-LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
+LIB_DEPENDS+= libspf2.so:${PORTSDIR}/mail/libspf2
USES= qmail
USE_BZIP2= yes