aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-09 00:49:12 +0800
committerrafan <rafan@FreeBSD.org>2006-08-09 00:49:12 +0800
commitd9bd99b328156e6c3d960d535462c403df953e9d (patch)
tree7732f71c75a1d83510438539c4412229eed7b0bf /mail
parent2e581548d52347b691ef0a6b5683f5fc651dd530 (diff)
downloadfreebsd-ports-gnome-d9bd99b328156e6c3d960d535462c403df953e9d.tar.gz
freebsd-ports-gnome-d9bd99b328156e6c3d960d535462c403df953e9d.tar.zst
freebsd-ports-gnome-d9bd99b328156e6c3d960d535462c403df953e9d.zip
- Fix build on 4.x
PR: ports/101555 Submitted by: Mark Starovoytov <mark_sf at kikg.ifmo.ru> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/libsieve/Makefile7
-rw-r--r--mail/libsieve/files/patch-freebsd4_fix47
2 files changed, 52 insertions, 2 deletions
diff --git a/mail/libsieve/Makefile b/mail/libsieve/Makefile
index 8e2afff928cc..d80c1c97e5ac 100644
--- a/mail/libsieve/Makefile
+++ b/mail/libsieve/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: libsieve
-# Date created: 4 August 2006
-# Whom: Mark Starovoytov <mark_sf@kikg.ifmo.ru>
+# Date created: 4 August 2006
+# Whom: Mark Starovoytov <mark_sf@kikg.ifmo.ru>
#
# $FreeBSD$
#
PORTNAME= libsieve
PORTVERSION= 2.1.13
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= libsieve
@@ -22,5 +23,7 @@ USE_GMAKE= yes
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
USE_LDCONFIG= yes
+# get rid of the `size_t' problem in header.y
+USE_GCC= 3.2+
.include <bsd.port.mk>
diff --git a/mail/libsieve/files/patch-freebsd4_fix b/mail/libsieve/files/patch-freebsd4_fix
new file mode 100644
index 000000000000..9bc8b5e54f6f
--- /dev/null
+++ b/mail/libsieve/files/patch-freebsd4_fix
@@ -0,0 +1,47 @@
+--- src/sv_interface/tree.h.orig Tue Jul 18 17:17:23 2006
++++ src/sv_interface/tree.h Mon Aug 7 10:11:05 2006
+@@ -30,7 +30,7 @@
+
+ #include "comparator.h"
+
+-//#include <sys/types.h>
++#include <sys/types.h>
+ #include "regex.h"
+
+
+--- src/sv_parser/comparator.h Tue Jul 18 17:15:16 2006
++++ src/sv_parser/comparator.h Mon Aug 7 10:05:29 2006
+@@ -27,6 +27,8 @@
+ #ifndef COMPARATOR_H
+ #define COMPARATOR_H
+
++// sys/types.h was required prior to the FreeBSD 5.0
++#include <sys/types.h>
+ #include "regex.h"
+
+ /* compares pat to text; returns 1 if it's true, 0 otherwise
+--- src/sv_parser/sieve.y.orig Mon Jul 24 14:24:53 2006
++++ src/sv_parser/sieve.y Mon Aug 7 10:28:04 2006
+@@ -36,6 +36,9 @@
+ #include <ctype.h>
+
+ /* sv_regex */
++/* POSIX says that <sys/types.h> must be included (by the caller) before
++ <regex.h>. */
++#include <sys/types.h>
+ #include "regex.h"
+
+ /* sv_parser */
+--- src/sv_util/xsize.h.orig Tue Jul 18 17:15:16 2006
++++ src/sv_util/xsize.h Mon Aug 7 10:47:36 2006
+@@ -26,6 +26,10 @@
+ #include <limits.h>
+ #if HAVE_STDINT_H
+ # include <stdint.h>
++#else
++// stdint.h was introduced in FreeBSD 5.0
++// limits.h in 4.0 has SIZE_T_MAX, not SIZE_MAX
++# define SIZE_MAX SIZE_T_MAX
+ #endif
+
+ /* The size of memory objects is often computed through expressions of