aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-24 17:15:03 +0800
committermiwi <miwi@FreeBSD.org>2007-06-24 17:15:03 +0800
commitea5841fdfea669b4d16ae02f3d7818bda24fb0dc (patch)
tree2ef67e6cb92a5109c8553d9d6fcb03284cb2946f /mail
parent4b3612ef36cdd77328a8eac2f0981fa7a743b4b8 (diff)
downloadfreebsd-ports-gnome-ea5841fdfea669b4d16ae02f3d7818bda24fb0dc.tar.gz
freebsd-ports-gnome-ea5841fdfea669b4d16ae02f3d7818bda24fb0dc.tar.zst
freebsd-ports-gnome-ea5841fdfea669b4d16ae02f3d7818bda24fb0dc.zip
- Fix build with FreeBSD 5.X
PR: 113966 Submitted by: Alex Samorukov <samm@os2.kiev.ua> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/spamd/files/patch-makefile13
-rw-r--r--mail/spamd/files/patch-spamlogd15
2 files changed, 28 insertions, 0 deletions
diff --git a/mail/spamd/files/patch-makefile b/mail/spamd/files/patch-makefile
new file mode 100644
index 000000000000..18f76d9465c1
--- /dev/null
+++ b/mail/spamd/files/patch-makefile
@@ -0,0 +1,13 @@
+--- spamlogd/Makefile.old Mon Apr 2 01:33:46 2007
++++ spamlogd/Makefile Sat Jun 23 15:29:03 2007
+@@ -4,6 +4,10 @@
+ SRCS= spamlogd.c sync.c
+ MAN= spamlogd.8
+
++.if ${OSVERSION} < 601000
++SRCS+= ../spamd/strtonum.c
++.endif
++
+ CFLAGS+= -Wall -Wstrict-prototypes -I${.CURDIR}/../spamd
+ LDADD+= -lpcap -lcrypto -lmd
+ DPADD+= ${LIBPCAP} ${LIBMD}
diff --git a/mail/spamd/files/patch-spamlogd b/mail/spamd/files/patch-spamlogd
new file mode 100644
index 000000000000..1a3e2d35b5a6
--- /dev/null
+++ b/mail/spamd/files/patch-spamlogd
@@ -0,0 +1,15 @@
+--- spamlogd/spamlogd.c.orig Sat Jun 23 15:28:14 2007
++++ spamlogd/spamlogd.c Sat Jun 23 15:28:27 2007
+@@ -158,10 +158,12 @@
+
+ pcap_freecode(&bpfp);
+
++#ifdef BIOLOCK
+ if (ioctl(pcap_fileno(hpcap), BIOCLOCK) < 0) {
+ logmsg(LOG_ERR, "BIOCLOCK: %s", strerror(errno));
+ return (-1);
+ }
++#endif
+
+ return (0);
+ }