aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 05:05:49 +0800
committerpav <pav@FreeBSD.org>2009-01-06 05:05:49 +0800
commitfb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb (patch)
tree1f6b633bd7844aa504f407e530e6892e38d0b9c5 /mail
parent54aa386a510858774daf943c9ab8069883f977c7 (diff)
downloadfreebsd-ports-gnome-fb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb.tar.gz
freebsd-ports-gnome-fb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb.tar.zst
freebsd-ports-gnome-fb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'mail')
-rw-r--r--mail/bsmtp/Makefile4
-rw-r--r--mail/cone/Makefile4
-rw-r--r--mail/courier/files/pkg-install.in14
-rw-r--r--mail/cyrus-imapd22/Makefile3
-rw-r--r--mail/cyrus-imapd23/Makefile3
-rw-r--r--mail/cyrus-imapd24/Makefile3
-rw-r--r--mail/maildrop/Makefile4
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt14/Makefile2
-rw-r--r--mail/spamd/Makefile4
-rw-r--r--mail/xc-mail/Makefile6
12 files changed, 7 insertions, 44 deletions
diff --git a/mail/bsmtp/Makefile b/mail/bsmtp/Makefile
index f504d5ec6aa9..3b7cac4cdf79 100644
--- a/mail/bsmtp/Makefile
+++ b/mail/bsmtp/Makefile
@@ -23,12 +23,8 @@ CONFIGURE_ARGS= --redo
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500024
-UUPREFIX= /usr
-.else
RUN_DEPENDS= ${LOCALBASE}/bin/uux:${PORTSDIR}/net/freebsd-uucp
UUPREFIX= ${LOCALBASE}
-.endif
post-patch:
@${CP} ${WRKSRC}/bsmtp.m4.8.9.in ${WRKSRC}/bsmtp.m4.8.10.in
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index f4aad55f6e60..55d036509e07 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -41,10 +41,6 @@ INSTALL_TARGET= install-strip
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502010
-IGNORE= not supported on FreeBSD versions before 5.2.1-RELEASE
-.endif
-
.if ${OSVERSION} > 700032 || (${OSVERSION} < 700000 && ${OSVERSION} > 602106)
CPPFLAGS+= -D_XOPEN_SOURCE_EXTENDED
.elif exists(${LOCALBASE}/include/ncurses/ncurses.h) || defined(WITH_NCURSESW)
diff --git a/mail/courier/files/pkg-install.in b/mail/courier/files/pkg-install.in
index 8a8adec92bf6..4edbdd45361c 100644
--- a/mail/courier/files/pkg-install.in
+++ b/mail/courier/files/pkg-install.in
@@ -52,12 +52,6 @@ replace() {
}
if [ ":$2" = ":POST-INSTALL" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
if yesno "Would you like to activate Courier in /etc/mail/mailer.conf" n; then
mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
echo "#" > /etc/mail/mailer.conf
@@ -70,12 +64,4 @@ if [ ":$2" = ":POST-INSTALL" ]; then
echo "newaliases ${PKG_PREFIX}/sbin/makealiases" >> /etc/mail/mailer.conf
echo "Done."
fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Courier versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/bin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/bin/mailq
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/makealiases
- echo "Done."
- fi
- fi
fi
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index b58ed112b25b..fa266221d229 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -133,8 +133,7 @@ PLIST_SUB+= LDAP_PTLOADER="@comment "
EXTRA_PATCHES+= ${FILESDIR}/pass8bit.diff
.endif
-.if (!defined(MAKE_KERBEROS5) && ${OSVERSION} <= 500105) || \
- !exists(/usr/lib/libkrb5.a)
+.if !exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+=--disable-gssapi
.endif
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index e0484030fb72..a4ba6a51cc26 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -149,8 +149,7 @@ PLIST_SUB+= LDAP_PTLOADER=""
PLIST_SUB+= LDAP_PTLOADER="@comment "
.endif
-.if (!defined(MAKE_KERBEROS5) && ${OSVERSION} <= 500105) || \
- !exists(/usr/lib/libkrb5.a)
+.if !exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+=--disable-gssapi
.endif
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index e0484030fb72..a4ba6a51cc26 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -149,8 +149,7 @@ PLIST_SUB+= LDAP_PTLOADER=""
PLIST_SUB+= LDAP_PTLOADER="@comment "
.endif
-.if (!defined(MAKE_KERBEROS5) && ${OSVERSION} <= 500105) || \
- !exists(/usr/lib/libkrb5.a)
+.if !exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+=--disable-gssapi
.endif
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 847f14064ef3..af4f78b0d380 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -46,10 +46,6 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
.include <bsd.port.pre.mk>
-.if ${OSVERSION} <= 502010
-USE_GMAKE =yes
-.endif
-
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+= --with-db=gdbm
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 8c2889bd69d5..d8807e2719a7 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -398,7 +398,7 @@ CONFIGURE_ARGS+= --disable-gpgme
.if exists(${LOCALBASE}/bin/krb5-config)
LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
-.elif (defined(MAKE_KERBEROS5) && ${OSVERSION} > 500105) || exists(/usr/lib/libkrb5.a)
+.elif (defined(MAKE_KERBEROS5)) || exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-gss
USE_KRB5_SYS=YES
.endif
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 6ba71a187921..376d9b851d19 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -121,7 +121,7 @@ CFLAGS+= -I${PREFIX}/include/ncurses -I${PREFIX}/include
.if exists(${LOCALBASE}/bin/gss-client)
LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
-.elif (defined(MAKE_KERBEROS5) && (${OSVERSION} > 500105)) || exists(/usr/lib/libkrb5.a)
+.elif (defined(MAKE_KERBEROS5)) || exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-gss
USE_KRB5_SYS=YES
.endif
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 6ba71a187921..376d9b851d19 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -121,7 +121,7 @@ CFLAGS+= -I${PREFIX}/include/ncurses -I${PREFIX}/include
.if exists(${LOCALBASE}/bin/gss-client)
LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
-.elif (defined(MAKE_KERBEROS5) && (${OSVERSION} > 500105)) || exists(/usr/lib/libkrb5.a)
+.elif (defined(MAKE_KERBEROS5)) || exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-gss
USE_KRB5_SYS=YES
.endif
diff --git a/mail/spamd/Makefile b/mail/spamd/Makefile
index 1dd212439d18..d37fd1ace1c0 100644
--- a/mail/spamd/Makefile
+++ b/mail/spamd/Makefile
@@ -17,11 +17,7 @@ COMMENT= Traps spammers with a very slow smtp-login and return 4xx error
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502117
-BROKEN= OpenBSD 3.5 pf/pfctl is necessary for this port to function properly.
-.else
LOCAL_PFCTL= /sbin/pfctl
-.endif
USE_RC_SUBR?= obspamd obspamlogd
diff --git a/mail/xc-mail/Makefile b/mail/xc-mail/Makefile
index e57be030ee5c..848461a816a6 100644
--- a/mail/xc-mail/Makefile
+++ b/mail/xc-mail/Makefile
@@ -30,16 +30,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
post-patch:
-.if ${OSVERSION} > 502014
@${REINPLACE_CMD} -e "s|expr $1|expr -- $1|g" ${WRKSRC}/plugins/linkshared.in
@${REINPLACE_CMD} -e "s|expr $1|expr -- $1|g" ${WRKSRC}/src/linktool
-.endif
post-install:
chown ${BINOWN}:mail ${PREFIX}/bin/xc-mail
chmod g+s ${PREFIX}/bin/xc-mail
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>