aboutsummaryrefslogtreecommitdiffstats
path: root/math/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-05 15:58:52 +0800
committermiwi <miwi@FreeBSD.org>2007-01-05 15:58:52 +0800
commit0c52f5367e3ed4670ff8a8f2ee48ea68f6c4ba8b (patch)
tree24167de50d59ec34d8d033c40d649e5fb615509a /math/Makefile
parent70f3720119e693604cc210e7090288c69f8e5583 (diff)
downloadfreebsd-ports-gnome-0c52f5367e3ed4670ff8a8f2ee48ea68f6c4ba8b.tar.gz
freebsd-ports-gnome-0c52f5367e3ed4670ff8a8f2ee48ea68f6c4ba8b.tar.zst
freebsd-ports-gnome-0c52f5367e3ed4670ff8a8f2ee48ea68f6c4ba8b.zip
Msieve is a library and utility for factoring large integers using the most
powerful modern algorithms. It features a stable and very fast implementation of a self-initializing multiple polynomial quadratic sieve (MPQS), plus a highly experimental and unfinished number field sieve (NFS) implementation. Primary design goals are speed, portability and ease of use. Msieve claims to be the fastest implementation for factoring general inputs between 40 and 100 decimal digits. Author: Jason Papadopoulos <jasonp@boo.net> WWW: http://www.boo.net/~jasonp/qs.html PR: ports/107477 Submitted by: Daniel Roethlisberger <daniel at roe.ch>
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bfe8c7a87774..48d6c9bb9697 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -145,6 +145,7 @@
SUBDIR += mpexpr
SUBDIR += mpfr
SUBDIR += mprime
+ SUBDIR += msieve
SUBDIR += mtl
SUBDIR += mtrxmath
SUBDIR += mumps