aboutsummaryrefslogtreecommitdiffstats
path: root/math/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-07-05 16:18:12 +0800
committerwen <wen@FreeBSD.org>2010-07-05 16:18:12 +0800
commit4ada82255e7dfd1abcd38b50efcdec59be4f5e3d (patch)
tree4ad5d1010ab29f70a6ef934d745af8dc1a86ef92 /math/Makefile
parentc4712ec175b40b66a759f78f8c786deaa5fce64c (diff)
downloadfreebsd-ports-gnome-4ada82255e7dfd1abcd38b50efcdec59be4f5e3d.tar.gz
freebsd-ports-gnome-4ada82255e7dfd1abcd38b50efcdec59be4f5e3d.tar.zst
freebsd-ports-gnome-4ada82255e7dfd1abcd38b50efcdec59be4f5e3d.zip
numexpr - Fast numerical array expression evaluator for Python and NumPy.
The numexpr package evaluates multiple-operator array expressions many times faster than NumPy can. It accepts the expression as a string, analyzes it, rewrites it more efficiently, and compiles it to faster Python code on the fly. It's the next best thing to writing the expression in C and compiling it with a specialized just-in-time (JIT) compiler, i.e. it does not require a compiler at runtime. Also, numexpr has support for the Intel VML (Vector Math Library) -- integrated in Intel MKL (Math Kernel Library) --, allowing nice speed-ups when computing transcendental functions (like trigonometrical, exponentials...) on top of Intel-compatible platforms. This support also allows to use multiple cores in your computations. WWW: http://code.google.com/p/numexpr/ PR: ports/148372 Submitted by: Ju Pengfei <jupengfei@gmail.com> Feature safe: yes
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0bd6eb9b047d..09760b34a1cd 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -453,6 +453,7 @@
SUBDIR += py-networkx
SUBDIR += py-numarray
SUBDIR += py-numeric
+ SUBDIR += py-numexpr
SUBDIR += py-numpy
SUBDIR += py-plastex
SUBDIR += py-probstat