aboutsummaryrefslogtreecommitdiffstats
path: root/math/Makefile
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-01-04 17:32:22 +0800
committerpgj <pgj@FreeBSD.org>2010-01-04 17:32:22 +0800
commit660283bc42952eb092b5529c82c535c5ec11db28 (patch)
tree3e7472aa2332bdb17924bb367a272ba5a83c7944 /math/Makefile
parented52b17518e19a18b735fc85419190f64e891da6 (diff)
downloadfreebsd-ports-gnome-660283bc42952eb092b5529c82c535c5ec11db28.tar.gz
freebsd-ports-gnome-660283bc42952eb092b5529c82c535c5ec11db28.tar.zst
freebsd-ports-gnome-660283bc42952eb092b5529c82c535c5ec11db28.zip
This Haskell package contains code for generating high quality random
numbers that follow either a uniform or normal distribution. The generated numbers are suitable for use in statistical applications. The uniform PRNG uses Marsaglia's MWC256 (also known as MWC8222) multiply-with-carry generator, which has a period of 2^8222 and fares well in tests of randomness. It is also extremely fast, between 2 and 3 times faster than the Mersenne Twister. WWW: http://darcs.serpentine.com/mwc-random PR: ports/142293 Submitted by: Jacula Modyun <jacula(at)gmail.com>
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index eee72a56acf5..4c1bf9eaee2d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -116,6 +116,7 @@
SUBDIR += hs-Agda-executable
SUBDIR += hs-category-extras
SUBDIR += hs-erf
+ SUBDIR += hs-mwc-random
SUBDIR += hs-probability
SUBDIR += igraph
SUBDIR += isabelle