aboutsummaryrefslogtreecommitdiffstats
path: root/math/algae
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-09 18:00:56 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-09 18:00:56 +0800
commitb3e5bf55ce903c1bdd5f7693bf82752d1ea185ff (patch)
tree328aa58f5ab9b98b84491a471411d44a6b4967a4 /math/algae
parentacd1d787cb55f1c62495f35e8b36edc9d94c2bea (diff)
downloadfreebsd-ports-gnome-b3e5bf55ce903c1bdd5f7693bf82752d1ea185ff.tar.gz
freebsd-ports-gnome-b3e5bf55ce903c1bdd5f7693bf82752d1ea185ff.tar.zst
freebsd-ports-gnome-b3e5bf55ce903c1bdd5f7693bf82752d1ea185ff.zip
- Unbreak parallel (-jX) builds and remove disgraceful MAKE_JOBS_UNSAFE
- Sort the knobs, remove useless global modifiers from sed(1) regex' - Define LICENSE (GPLv2), augment port description while I am here
Diffstat (limited to 'math/algae')
-rw-r--r--math/algae/Makefile18
-rw-r--r--math/algae/files/patch-Makefile.in126
-rw-r--r--math/algae/pkg-descr5
3 files changed, 139 insertions, 10 deletions
diff --git a/math/algae/Makefile b/math/algae/Makefile
index 565209488d14..8d45b4fe4ad3 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -10,27 +10,27 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Programming language for numerical analysis
+LICENSE= GPLv2
+
+USE_FORTRAN= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
ALGAE_VERSION= ${PORTVERSION}
PLIST_SUB= ALGAE_VERSION=${ALGAE_VERSION}
-MAN1= algae.1
-INFO= algae
-
-MAKE_JOBS_UNSAFE= yes
-USE_FORTRAN= yes
LDFLAGS+= -L`${CAT} ${WRKSRC}/LIBDIR`/../../.. -L`${CAT} ${WRKSRC}/LIBDIR` -L${LOCALBASE}/lib
FORTRANLIBS= gfortranbegin gfortran
+MAN1= ${PORTNAME}.1
+INFO= ${PORTNAME}
+
post-patch:
- @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,g' \
+ @${REINPLACE_CMD} -e 's,<malloc\.h>,<stdlib.h>,' \
${WRKSRC}/src/mem.h \
${WRKSRC}/superlu/sp_coletree.c \
${WRKSRC}/superlu/util.h
-
- @${REINPLACE_CMD} -e 's,%%FORTRANLIBS%%,${FORTRANLIBS},g' \
+ @${REINPLACE_CMD} -e 's,%%FORTRANLIBS%%,${FORTRANLIBS},' \
${WRKSRC}/configure.in
pre-configure:
@@ -39,7 +39,7 @@ pre-configure:
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
+BROKEN= does not compile on ${ARCH}
.endif
.include <bsd.port.post.mk>
diff --git a/math/algae/files/patch-Makefile.in b/math/algae/files/patch-Makefile.in
index 8bcb294cbf20..e083595439b0 100644
--- a/math/algae/files/patch-Makefile.in
+++ b/math/algae/files/patch-Makefile.in
@@ -15,3 +15,129 @@
# Directory in which to install the algae tools.
tooldir = $(datadir)/algae/$(VERSION_NUMBER)/tools
+@@ -150,19 +150,19 @@
+ # Compile the source code.
+
+ source: @BLAS@ @LAPACK@
+- cd superlu; $(MAKE) RC0=$(RC0)
+- cd arpack; $(MAKE)
+- cd src; $(MAKE) RC0=$(RC0)
++ $(MAKE) -C superlu RC0=$(RC0)
++ $(MAKE) -C arpack
++ $(MAKE) -C src RC0=$(RC0)
+ .PHONY: source
+
+ # Compile the BLAS and LAPACK libraries, if required.
+
+ xblas:
+- cd blas; $(MAKE)
++ $(MAKE) -C blas
+ .PHONY: xblas
+
+ xlapack:
+- cd lapack; $(MAKE)
++ $(MAKE) -C lapack
+ .PHONY: xlapack
+
+ check: source
+@@ -180,13 +180,13 @@
+ # Run test cases.
+
+ check:
+- cd test; $(MAKE)
++ $(MAKE) -C test
+ .PHONY: check
+
+ # Run some simple timing tests.
+
+ times:
+- cd timing; $(MAKE)
++ $(MAKE) -C timing
+ .PHONY: times
+
+ # <<<< This section is deleted in the "binary" distribution.
+@@ -194,11 +194,11 @@
+ # Make documentation.
+
+ info:
+- cd doc; $(MAKE) info
++ $(MAKE) -C doc info
+ .PHONY: info
+
+ dvi:
+- cd doc; $(MAKE) dvi
++ $(MAKE) -C doc dvi
+ .PHONY: dvi
+
+ # ========================== Distribution =========================
+@@ -211,9 +211,7 @@
+ ln $$file $(distdir) > /dev/null 2>&1 || cp $$file $(distdir); \
+ done
+ for dir in $(SUBDIRS); do \
+- cd $${dir}; \
+- $(MAKE) distdir=../$(distdir)/$$dir dist; \
+- cd ..; \
++ $(MAKE) -C $${dir} distdir=../$(distdir)/$$dir dist; \
+ done
+ mv $(distdir) algae-$(VERSION_NUMBER)
+ tar chf algae-$(VERSION_NUMBER).tar algae-$(VERSION_NUMBER)
+@@ -230,9 +228,7 @@
+ done
+ awk '/<<[<]</,/>>[>]>/ {next} {print}' Makefile > $(distdir)/Makefile
+ for dir in $(BINSUBDIRS); do \
+- cd $${dir}; \
+- $(MAKE) distdir=../$(distdir)/$$dir binaries; \
+- cd ..; \
++ $(MAKE) -C $${dir} distdir=../$(distdir)/$$dir binaries; \
+ done
+ mv $(distdir) algae-$(VERSION_NUMBER)
+ tar chf algae-$(VERSION_NUMBER)-@host@.tar algae-$(VERSION_NUMBER)
+@@ -249,8 +245,8 @@
+ for file in $(WEBDISTFILES); do \
+ ln $$file $(distdir) > /dev/null 2>&1 || cp $$file $(distdir); \
+ done
+- cd doc; $(MAKE) distdir=../$(distdir) web
+- cd $(distdir); tar chf ../algae-web-$(VERSION_NUMBER).tar .
++ $(MAKE) -C doc distdir=../$(distdir) web
++ tar -C $(distdir) -chf ../algae-web-$(VERSION_NUMBER).tar .
+ rm -rf $(distdir)
+ gzip algae-web-$(VERSION_NUMBER).tar
+ .PHONY: web
+@@ -278,7 +274,7 @@
+ @echo "it deletes files that may require special tools to rebuild."
+
+ clean mostlyclean distclean maintainer-clean::
+- for dir in $(SUBDIRS); do cd $${dir}; $(MAKE) $@; cd ..; done
++ for dir in $(SUBDIRS); do $(MAKE) -C $${dir} $@; done
+
+ clean mostlyclean distclean maintainer-clean::
+ rm -f a.out core conft* algae-*.tar algae-*.tar.gz
+@@ -297,12 +293,9 @@
+ $(INSTALL_DATA) algae.A $(RC0)
+ $(INSTALL_DATA) COPYING $(htmldir)
+ $(INSTALL_DATA) LICENSE $(htmldir)
+- cd src; \
+- $(MAKE) bindir=$(bindir) install
+- cd tools; \
+- $(MAKE) tooldir=$(tooldir) install
+- cd doc; \
+- $(MAKE) mandir=$(mandir) datadir=$(datadir) \
++ $(MAKE) -C src bindir=$(bindir) install
++ $(MAKE) -C tools tooldir=$(tooldir) install
++ $(MAKE) -C doc mandir=$(mandir) datadir=$(datadir) \
+ manext=$(manext) infodir=$(infodir) htmldir=$(htmldir) install
+ .PHONY: install
+
+@@ -318,9 +311,9 @@
+
+ uninstall:
+ rm -f $(RC0)
+- cd src; $(MAKE) bindir=$(bindir) uninstall
+- cd tools; $(MAKE) tooldir=$(tooldir) uninstall
+- cd doc; $(MAKE) mandir=$(mandir) manext=$(manext) \
++ $(MAKE) -C src bindir=$(bindir) uninstall
++ $(MAKE) -C tools tooldir=$(tooldir) uninstall
++ $(MAKE) -C doc mandir=$(mandir) manext=$(manext) \
+ infodir=$(infodir) htmldir=$(htmldir) uninstall
+ rm -f $(htmldir)/COPYING $(htmldir)/LICENSE
+ -rmdir $(rcdir) $(htmldir) $(tooldir) \
diff --git a/math/algae/pkg-descr b/math/algae/pkg-descr
index 2476bd39c0d8..b8c4e4107022 100644
--- a/math/algae/pkg-descr
+++ b/math/algae/pkg-descr
@@ -1,3 +1,6 @@
-Algae is a programming language for numerical analysis.
+Algae is a programming language for numerical analysis. It was written in
+the Boeing Company to fulfill their need for a fast and versatile tool,
+capable of handling large systems. Algae has been applied to interesting
+problems in aerospace and related fields for more than a decade.
WWW: http://algae.sourceforge.net/