aboutsummaryrefslogtreecommitdiffstats
path: root/math/analitza
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /math/analitza
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'math/analitza')
-rw-r--r--math/analitza/Makefile10
-rw-r--r--math/analitza/distinfo4
-rw-r--r--math/analitza/pkg-plist28
3 files changed, 30 insertions, 12 deletions
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index aa42f6fd44c2..0d70578dc6d4 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -5,17 +5,19 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
-COMMENT= A library from KDE Education project
+COMMENT= Library from KDE Education project
CONFLICTS_INSTALL= kalgebra-4.7.* kdeedu-4.[0-6].*
-USE_XZ= yes
+USE_XZ= yes
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT4= corelib gui opengl svg xml \
+ moc_build qmake_build rcc_build uic_build
+USE_GL= glu
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/math/analitza/distinfo b/math/analitza/distinfo
index 7cae2c15f40b..f1e987789708 100644
--- a/math/analitza/distinfo
+++ b/math/analitza/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/analitza-4.9.5.tar.xz) = 57d156362c62f7a109e2b31704d0265a668b5064901161670c1f0d7d2abcdc4e
-SIZE (KDE/analitza-4.9.5.tar.xz) = 146196
+SHA256 (KDE/4.10.1/analitza-4.10.1.tar.xz) = 69dbdbac2445632934afcdeeda807e87527eb506218cef015c0212c4311495bd
+SIZE (KDE/4.10.1/analitza-4.10.1.tar.xz) = 178588
diff --git a/math/analitza/pkg-plist b/math/analitza/pkg-plist
index a803207e744a..d08f5130cc78 100644
--- a/math/analitza/pkg-plist
+++ b/math/analitza/pkg-plist
@@ -5,6 +5,7 @@ include/analitza/analitzautils.h
include/analitza/analyzer.h
include/analitza/builtinmethods.h
include/analitza/expression.h
+include/analitza/expressionstream.h
include/analitza/expressiontype.h
include/analitza/importqobjectmetatype.h
include/analitza/object.h
@@ -17,14 +18,22 @@ include/analitza/vector.h
include/analitzagui/algebrahighlighter.h
include/analitzagui/analitzaguiexport.h
include/analitzagui/expressionedit.h
-include/analitzagui/function.h
-include/analitzagui/functionfactory.h
-include/analitzagui/functionsmodel.h
-include/analitzagui/functionspainter.h
-include/analitzagui/functionsview.h
-include/analitzagui/graph2d.h
include/analitzagui/operatorsmodel.h
+include/analitzagui/plotsview2d.h
+include/analitzagui/plotsview3d.h
include/analitzagui/variablesmodel.h
+include/analitzaplot/analitzaplotexport.h
+include/analitzaplot/functiongraph.h
+include/analitzaplot/planecurve.h
+include/analitzaplot/plotitem.h
+include/analitzaplot/plotsdictionarymodel.h
+include/analitzaplot/plotsfactory.h
+include/analitzaplot/plotsmodel.h
+include/analitzaplot/plotter2d.h
+include/analitzaplot/plotter3d.h
+include/analitzaplot/plottingenums.h
+include/analitzaplot/spacecurve.h
+include/analitzaplot/surface.h
lib/cmake/analitza/AnalitzaConfig.cmake
lib/cmake/analitza/AnalitzaTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/analitza/AnalitzaTargets.cmake
@@ -34,7 +43,14 @@ lib/libanalitza.so.5.0.1
lib/libanalitzagui.so
lib/libanalitzagui.so.5
lib/libanalitzagui.so.5.0.1
+lib/libanalitzaplot.so
+lib/libanalitzaplot.so.5
+lib/libanalitzaplot.so.5.0.1
+share/apps/libanalitza/plots/basic_curves.plots
+@dirrm share/apps/libanalitza/plots
+@dirrm share/apps/libanalitza
@dirrm lib/cmake/analitza
@dirrmtry lib/cmake
+@dirrm include/analitzaplot
@dirrm include/analitzagui
@dirrm include/analitza