aboutsummaryrefslogtreecommitdiffstats
path: root/math/armadillo
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2015-05-03 03:39:43 +0800
committerdanilo <danilo@FreeBSD.org>2015-05-03 03:39:43 +0800
commitedefe5661ae4b1edfbc631bed9eea6b9dd0d7038 (patch)
tree188272baa3fb284e5e971ea9cfa45bcc520e74de /math/armadillo
parente5d2e2c92a7f26314b134ec4182b876d48f64d1c (diff)
downloadfreebsd-ports-gnome-edefe5661ae4b1edfbc631bed9eea6b9dd0d7038.tar.gz
freebsd-ports-gnome-edefe5661ae4b1edfbc631bed9eea6b9dd0d7038.tar.zst
freebsd-ports-gnome-edefe5661ae4b1edfbc631bed9eea6b9dd0d7038.zip
- Update to 5.100.1
- Add support to superlu library [1] Suggested by: Conrad Sanderson (author) [1]
Diffstat (limited to 'math/armadillo')
-rw-r--r--math/armadillo/Makefile5
-rw-r--r--math/armadillo/distinfo4
-rw-r--r--math/armadillo/files/patch-include+armadillo_bits+config.hpp17
-rw-r--r--math/armadillo/pkg-plist3
4 files changed, 19 insertions, 10 deletions
diff --git a/math/armadillo/Makefile b/math/armadillo/Makefile
index bb4ceb48642f..314d23c6a36c 100644
--- a/math/armadillo/Makefile
+++ b/math/armadillo/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= armadillo
-PORTVERSION= 5.000.1
+PORTVERSION= 5.100.1
CATEGORIES= math
MASTER_SITES= SF/arma
@@ -12,7 +12,8 @@ LICENSE= MPL
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
libarpack.so:${PORTSDIR}/math/arpack \
- libhdf5.so:${PORTSDIR}/science/hdf5
+ libhdf5.so:${PORTSDIR}/science/hdf5 \
+ libsuperlu.so:${PORTSDIR}/math/superlu
USES= cmake blaslapack
USE_LDCONFIG= yes
diff --git a/math/armadillo/distinfo b/math/armadillo/distinfo
index 41042c4b3761..54c58ea69639 100644
--- a/math/armadillo/distinfo
+++ b/math/armadillo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (armadillo-5.000.1.tar.gz) = 8ca55fbfce220517374a879ddc0c79e1afd3993f89cc58621aa502e9533f3cdb
-SIZE (armadillo-5.000.1.tar.gz) = 5425382
+SHA256 (armadillo-5.100.1.tar.gz) = cf4c3c700e163689b187dd987756d963e24ca5f0834b6dad59832300d55860c7
+SIZE (armadillo-5.100.1.tar.gz) = 5428805
diff --git a/math/armadillo/files/patch-include+armadillo_bits+config.hpp b/math/armadillo/files/patch-include+armadillo_bits+config.hpp
index 8e9286ec5423..a0941da62357 100644
--- a/math/armadillo/files/patch-include+armadillo_bits+config.hpp
+++ b/math/armadillo/files/patch-include+armadillo_bits+config.hpp
@@ -1,15 +1,22 @@
---- include/armadillo_bits/config.hpp.orig 2015-01-09 19:09:21.294357075 -0500
-+++ include/armadillo_bits/config.hpp 2015-01-09 19:12:51.862339555 -0500
-@@ -24,7 +24,7 @@
+--- include/armadillo_bits/config.hpp.orig 2015-04-10 05:54:47 UTC
++++ include/armadillo_bits/config.hpp
+@@ -24,13 +24,13 @@
#endif
#if !defined(ARMA_USE_ARPACK)
-// #define ARMA_USE_ARPACK
+#define ARMA_USE_ARPACK
//// Uncomment the above line if you have ARPACK or a high-speed replacement for ARPACK.
- //// ARPACK is required for eigendecompositions of sparse matrices, eg. eigs_sym()
+ //// ARPACK is required for eigendecompositions of sparse matrices, eg. eigs_sym(), svds()
#endif
-@@ -54,7 +54,7 @@
+
+ #if !defined(ARMA_USE_SUPERLU)
+-// #define ARMA_USE_SUPERLU
++#define ARMA_USE_SUPERLU
+ //// Uncomment the above line if you have SuperLU.
+ //// SuperLU is used for solving sparse linear systems via spsolve()
+ //// Caveat: only SuperLU version 4.3 can be used!
+@@ -68,7 +68,7 @@
//// Uncomment the above line if you want to use Intel MKL mkl_malloc() and mkl_free() instead of standard malloc() and free()
// #define ARMA_USE_ATLAS
diff --git a/math/armadillo/pkg-plist b/math/armadillo/pkg-plist
index 5b97fd18a43e..75e863afe937 100644
--- a/math/armadillo/pkg-plist
+++ b/math/armadillo/pkg-plist
@@ -133,6 +133,7 @@ include/armadillo_bits/fn_hist.hpp
include/armadillo_bits/fn_histc.hpp
include/armadillo_bits/fn_inplace_strans.hpp
include/armadillo_bits/fn_inplace_trans.hpp
+include/armadillo_bits/fn_interp1.hpp
include/armadillo_bits/fn_inv.hpp
include/armadillo_bits/fn_join.hpp
include/armadillo_bits/fn_kron.hpp
@@ -422,7 +423,7 @@ include/armadillo_bits/xvec_htrans_bones.hpp
include/armadillo_bits/xvec_htrans_meat.hpp
lib/libarmadillo.so
lib/libarmadillo.so.5
-lib/libarmadillo.so.5.000.1
+lib/libarmadillo.so.5.100.1
share/Armadillo/CMake/ArmadilloConfig.cmake
share/Armadillo/CMake/ArmadilloConfigVersion.cmake
share/Armadillo/CMake/ArmadilloLibraryDepends-release.cmake