aboutsummaryrefslogtreecommitdiffstats
path: root/math/asymptote
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /math/asymptote
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'math/asymptote')
-rw-r--r--math/asymptote/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index bdb26481ab72..04b9d01f236c 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -50,10 +50,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-latex=${LOCALBASE}/share/texmf/tex/latex \
--with-context=${LOCALBASE}/share/texmf/tex/context/third
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" \
- LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" \
- CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
+CONFIGURE_ENV= LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= ${CONFIGURE_ENV}
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr