aboutsummaryrefslogtreecommitdiffstats
path: root/math/atlas
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-02-14 06:28:14 +0800
committerbf <bf@FreeBSD.org>2012-02-14 06:28:14 +0800
commit772fcd15d63ae13c44c042ffc36f490ab7ae3703 (patch)
treecc599cd3ba0b1c7dfe2294f82565803e577877ca /math/atlas
parent40f647fca66e27d8553ced02a7cfe2558db848ad (diff)
downloadfreebsd-ports-gnome-772fcd15d63ae13c44c042ffc36f490ab7ae3703.tar.gz
freebsd-ports-gnome-772fcd15d63ae13c44c042ffc36f490ab7ae3703.tar.zst
freebsd-ports-gnome-772fcd15d63ae13c44c042ffc36f490ab7ae3703.zip
restore the explicit pointer bitwidth configure argument, to prevent
misconfiguration on some machines PR: 162686 Submitted by: truckman (different patch)
Diffstat (limited to 'math/atlas')
-rw-r--r--math/atlas/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index ae7bf18f519a..3cc770cbd33a 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -7,6 +7,7 @@
PORTNAME= atlas
PORTVERSION= 3.8.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math
MASTER_SITES= SF/math-${PORTNAME}/Stable/${PORTVERSION}
@@ -46,6 +47,12 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
+.if !empty(ARCH:M*64*)
+POINTER?= 64
+.else
+POINTER?= 32
+.endif
+
.if defined(MAINTAINER_MODE)
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
.endif
@@ -135,7 +142,7 @@ do-configure:
../configure --cc="${CC}" --cflags="${CFLAGS}" \
--prefix="${PREFIX}" -v 2 $${TIMEFLAG} ${ARCHDEFFLAG} \
-Ss f77lib " " -Ss pmake "${MAKE} ${_MAKE_JOBS}" \
- -Fa alg "${STATIC_FLAGS} "
+ -Fa alg "${STATIC_FLAGS} " -b ${POINTER}
@${SED} -ne "\|F77FLAGS =|p" ${WRKSRC}/static/Make.inc \
>> ${WRKSRC}/saved_flags
@@ -162,7 +169,7 @@ do-build:
--with-netlib-lapack="${WRKSRC}/${opt}/liblapack_${opt}.a" \
--prefix="${PREFIX}" -v 2 $${TIMEFLAG} ${ARCHDEFFLAG} \
-Ss f77lib " " -Ss pmake "${MAKE} ${_MAKE_JOBS}" \
- -Fa alg "${${opt:U}_FLAGS} " ; \
+ -Fa alg "${${opt:U}_FLAGS} " -b ${POINTER} ; \
if [ "x${WITH_ARCHDEF}" != "x" ] ; then \
if [ "x${ARCHDEF}" != "xNONE" ] ; then \
if [ -f ${ARCHDEF} ] ; then \
@@ -196,7 +203,7 @@ post-build:
.endfor
.if defined(WITH_SHARED)
@${ECHO_CMD} "Building ATLAS shared libraries:"
- @F77FLAGS=`${MAKE} -f ${WRKSRC}/saved_flags -V F77FLAGS` ; \
+ @F77FLAGS="`${MAKE} -f ${WRKSRC}/saved_flags -V F77FLAGS` ${EXTRA_FFLAGS}" ; \
cd ${WRKSRC}/shared/lib ; \
${L1}libatlas.so.2 -o libatlas.so.2 libatlas.a ${L2} ; \
${L1}libf77blas.so.2 -o libf77blas.so.2 libf77blas.a ${L2} libatlas.so.2 ; \