aboutsummaryrefslogtreecommitdiffstats
path: root/math/atlas
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-15 18:41:17 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-15 18:41:17 +0800
commitfcaf679806fcf55a75cd2ad8017b14123dddd94a (patch)
tree38ebc6a77f99c7a594465a0194f5ab4439e86bb4 /math/atlas
parent3c26cddd14f79840606f4d45c7b5506a9503e03b (diff)
downloadfreebsd-ports-gnome-fcaf679806fcf55a75cd2ad8017b14123dddd94a.tar.gz
freebsd-ports-gnome-fcaf679806fcf55a75cd2ad8017b14123dddd94a.tar.zst
freebsd-ports-gnome-fcaf679806fcf55a75cd2ad8017b14123dddd94a.zip
fix on p4 architecture
bump portrevision PR: 40321 Submitted by: maintainer
Diffstat (limited to 'math/atlas')
-rw-r--r--math/atlas/Makefile1
-rw-r--r--math/atlas/files/patch-aa15
2 files changed, 12 insertions, 4 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 086d95ecc4e7..e95f2d0e45a9 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -7,6 +7,7 @@
PORTNAME= atlas
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= math-atlas
diff --git a/math/atlas/files/patch-aa b/math/atlas/files/patch-aa
index 4267161e5a89..3787b5f644b8 100644
--- a/math/atlas/files/patch-aa
+++ b/math/atlas/files/patch-aa
@@ -1,6 +1,13 @@
---- config.c.orig Mon Jun 17 10:37:24 2002
-+++ config.c Fri Jun 21 09:23:31 2002
-@@ -2055,6 +2055,7 @@
+--- config.c.orig Mon Jun 17 09:37:24 2002
++++ config.c Mon Jul 15 18:39:46 2002
+@@ -2049,12 +2049,14 @@
+ if (!CmndOneLine(targ, "sysctl hw.model", ln))
+ {
+ if (strstr(ln, "Pentium Pro")) mach = IntPPRO;
++ else if (strstr(ln, "Pentium 4")) mach = IntP4;
+ else if (strstr(ln, "Pentium III")) mach = IntPIII;
+ else if (strstr(ln, "Pentium II ")) mach = IntPII;
+ else if (strstr(ln, "Athlon")) mach = AmdAthlon;
else if (strstr(ln, "AMD-K7")) mach = AmdAthlon;
else if (strstr(ln, "Pentium/P55C")) mach = IntP5MMX; /* sent by */
else if (strstr(ln, "Pentium")) mach=IntP5; /* Nakata Maho */
@@ -8,7 +15,7 @@
}
break;
default:;
-@@ -3024,6 +3025,9 @@
+@@ -3024,6 +3026,9 @@
}
if (USEWINF77) strcpy(F77, "$(BINdir)/winf77.exe");