aboutsummaryrefslogtreecommitdiffstats
path: root/math/atlas
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-03-19 12:20:12 +0800
committermaho <maho@FreeBSD.org>2004-03-19 12:20:12 +0800
commit780714db008339c4c38102711fbd74aa16e08c74 (patch)
treec384dc06392c8f740ef567822e32702e0a38aafb /math/atlas
parent9957108e73b3df162cfbe5f88ae280d5b299d04f (diff)
downloadfreebsd-ports-gnome-780714db008339c4c38102711fbd74aa16e08c74.tar.gz
freebsd-ports-gnome-780714db008339c4c38102711fbd74aa16e08c74.tar.zst
freebsd-ports-gnome-780714db008339c4c38102711fbd74aa16e08c74.zip
Backout previous change of PICFLAG, since
behaviour of -fPIC and -fpic are different. Here is the comment form obrien: -- "-fpic" is a [minor?] optimization for machines that can handle it: -fpic Generate position-independent code (PIC) suitable for use in a shared library, if supported for the target machine. Such code accesses all constant addresses through a global offset table (GOT). The dynamic loader resolves the GOT entries when the program starts (the dynamic loader is not part of GCC; it is part of the operating system). If the GOT size for the linked executable exceeds a machine-specific maximum size, you get an error message from the linker indicating that -fpic does not work; in that case, recompile with -fPIC instead. (These maximums are 16k on the m88k, 8k on the SPARC, and 32k on the m68k and RS/6000. The 386 has no such limit.) -fPIC If supported for the target machine, emit position-independent code, suitable for dynamic linking and avoiding any limit on the size of the global offset table. This option makes a difference on the m68k, m88k, and the SPARC. Thanks to: obrien
Diffstat (limited to 'math/atlas')
-rw-r--r--math/atlas/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 42e8ddbf50be..a3a0fc74d800 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -49,7 +49,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"