aboutsummaryrefslogtreecommitdiffstats
path: root/math/bargraph
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2012-04-05 05:37:37 +0800
committercs <cs@FreeBSD.org>2012-04-05 05:37:37 +0800
commitc68cc5723893fe3ece1152a4025e36040c01aae6 (patch)
treea3c396f7fa0974bccd2bd3505bdf7527c278b2d5 /math/bargraph
parentbaa5896f7812b87bd814bc46e2e0dafabcb2c240 (diff)
downloadfreebsd-ports-gnome-c68cc5723893fe3ece1152a4025e36040c01aae6.tar.gz
freebsd-ports-gnome-c68cc5723893fe3ece1152a4025e36040c01aae6.tar.zst
freebsd-ports-gnome-c68cc5723893fe3ece1152a4025e36040c01aae6.zip
Scriptable bar graph generator with stacked and clustered bars support, using
gnuplot to produce fig output and then mangle it to fill in the bars. Any number of clustered datasets are supported, as well as automatic averaging and other features. WWW: http://www.burningcutlery.com/derek/bargraph/ PR: ports/166410 Submitted by: Dereckson <dereckson@gmail.com> Approved by: wen@ (co-mentor) Feature safe: yes
Diffstat (limited to 'math/bargraph')
-rw-r--r--math/bargraph/Makefile41
-rw-r--r--math/bargraph/distinfo2
-rw-r--r--math/bargraph/pkg-descr6
-rw-r--r--math/bargraph/pkg-plist26
4 files changed, 75 insertions, 0 deletions
diff --git a/math/bargraph/Makefile b/math/bargraph/Makefile
new file mode 100644
index 000000000000..43c5c9b3f672
--- /dev/null
+++ b/math/bargraph/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: bargraph
+# Date created: 9 March 2012
+# Whom: Dereckson <dereckson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bargraph
+PORTVERSION= 4.7
+CATEGORIES= math
+MASTER_SITES= http://bargraphgen.googlecode.com/files/
+DISTNAME= bargraphgen-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Scriptable bar graph generator
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${LOCALBASE}/bin/fig2dev:${PORTSDIR}/print/transfig \
+ ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bargraph.pl ${PREFIX}/bin/bargraph
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+.if !defined (NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/samples/*.perf ${WRKSRC}/samples/*.png ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/bargraph/distinfo b/math/bargraph/distinfo
new file mode 100644
index 000000000000..c7c4a24c2f38
--- /dev/null
+++ b/math/bargraph/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bargraphgen-4.7.tgz) = 14d0f5deb40bf7346b46d2d17695c5f288af39e0edebdc798783f5d4e8195bc5
+SIZE (bargraphgen-4.7.tgz) = 777492
diff --git a/math/bargraph/pkg-descr b/math/bargraph/pkg-descr
new file mode 100644
index 000000000000..e97ae7d4375c
--- /dev/null
+++ b/math/bargraph/pkg-descr
@@ -0,0 +1,6 @@
+Scriptable bar graph generator with stacked and clustered bars support, using
+gnuplot to produce fig output and then mangle it to fill in the bars. Any number
+of clustered datasets are supported, as well as automatic averaging and other
+features.
+
+WWW: http://www.burningcutlery.com/derek/bargraph/
diff --git a/math/bargraph/pkg-plist b/math/bargraph/pkg-plist
new file mode 100644
index 000000000000..06193cb4a169
--- /dev/null
+++ b/math/bargraph/pkg-plist
@@ -0,0 +1,26 @@
+bin/bargraph
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster-pattern.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster-pattern.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_stacked.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_stacked.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorbar.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorbar.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/font.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/font.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/missing_data.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/missing_data.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/one_dataset_colors.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/one_dataset_colors.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stacked_100.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stacked_100.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stacked_var.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stacked_var.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/value_label.perf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/value_label.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%