aboutsummaryrefslogtreecommitdiffstats
path: root/math/blacs/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-10-19 10:14:59 +0800
committermaho <maho@FreeBSD.org>2004-10-19 10:14:59 +0800
commit20a2edcc5c7f598031b520b593b27e1c1598b796 (patch)
treee7cef118bfc992f55c8f777d62a7f26320249db0 /math/blacs/Makefile
parenta68994a4d9e503badede3ca3106ef6cecc3f1b20 (diff)
downloadfreebsd-ports-gnome-20a2edcc5c7f598031b520b593b27e1c1598b796.tar.gz
freebsd-ports-gnome-20a2edcc5c7f598031b520b593b27e1c1598b796.tar.zst
freebsd-ports-gnome-20a2edcc5c7f598031b520b593b27e1c1598b796.zip
1) fix build after changes to make(1) on FreeBSD
2) pass portlint, and also fix pkg-message as well. PR: 72261 Submitted by: thierry@
Diffstat (limited to 'math/blacs/Makefile')
-rw-r--r--math/blacs/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 11d3cfbb8cf6..85faf40c6c75 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -26,6 +26,8 @@ LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
atlas:${PORTSDIR}/math/atlas
BUILD_DEPENDS= ${LOCALBASE}/mpich/lib/libmpich.a:${PORTSDIR}/net/mpich
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
.include <bsd.port.pre.mk>
pre-fetch:
@@ -42,7 +44,8 @@ DEBUG_LEVEL= 0
pre-patch:
(${CP} ${WRKSRC}/BMAKES/Bmake.MPI-LINUX ${WRKSRC}/Bmake.inc)
post-patch:
- (${REINPLACE_CMD} -e 's,@WRKSRC@,${WRKSRC},g ; s,@DEBUG_LEVEL@,${DEBUG_LEVEL},g ; s,@PREFIX@,${PREFIX},g ; s,@CC@,${CC},g ; s,@CFLAGS@,${CFLAGS},g ; s,@F77@,${F77},g ; s,@FFLAGS@,${FFLAGS},g ; s,@F77EXTRAFLAGS@,${F77EXTRAFLAGS},g' ${WRKSRC}/Bmake.inc)
+ (${REINPLACE_CMD} -e 's,@WRKSRC@,${WRKSRC},g ; s,@DEBUG_LEVEL@,${DEBUG_LEVEL},g ; s,@PREFIX@,${PREFIX},g ; s,@CC@,${CC},g ; s,@CFLAGS@,${CFLAGS},g ; s,@F77@,${F77},g ; s,@FFLAGS@,${FFLAGS},g ; s,@F77EXTRAFLAGS@,${F77EXTRAFLAGS},g ; s, ARCH *.= ar, ARCMD = ar,' ${WRKSRC}/Bmake.inc)
+ ${REINPLACE_CMD} -e 's|\$$(ARCH)|$$(ARCMD)|' ${WRKSRC}/SRC/MPI/Makefile
do-build:
(cd ${WRKSRC}; make mpi; make tester)
@@ -70,6 +73,8 @@ do-install:
.endif
post-install:
- @${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}
+ @${SED} -e 's,/usr/local,${PREFIX},g' ${FILESDIR}/pkg-message.in \
+ > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>