aboutsummaryrefslogtreecommitdiffstats
path: root/math/blacs
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-07-24 09:42:21 +0800
committermaho <maho@FreeBSD.org>2006-07-24 09:42:21 +0800
commit80fb1ea3cbb0cd0a40107111aa5c4e15fbe8381a (patch)
treec4b241cff78430e384b6dd67ab14ff111af64e60 /math/blacs
parent0520076a0a899e49799d4d0893ac0e68045cfb88 (diff)
downloadfreebsd-ports-gnome-80fb1ea3cbb0cd0a40107111aa5c4e15fbe8381a.tar.gz
freebsd-ports-gnome-80fb1ea3cbb0cd0a40107111aa5c4e15fbe8381a.tar.zst
freebsd-ports-gnome-80fb1ea3cbb0cd0a40107111aa5c4e15fbe8381a.zip
Switch to MPICH2.
PR: 100755, 100756 Submitted by: thierry
Diffstat (limited to 'math/blacs')
-rw-r--r--math/blacs/Makefile11
-rw-r--r--math/blacs/files/patch-Bmake.inc4
-rw-r--r--math/blacs/files/pkg-message.in12
-rw-r--r--math/blacs/pkg-message12
4 files changed, 15 insertions, 24 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 9966d39fa137..f16ebab0dbfb 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blacs
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/blacs/
DISTNAME= BLACS
@@ -22,9 +22,11 @@ EXTRACT_ONLY= mpiblacs.tgz blacstester.tgz mpiblacs-patch03.tgz
MAINTAINER= maho@FreeBSD.org
COMMENT= The BLACS (Basic Linear Algebra Communication Subprograms)
-BUILD_DEPENDS= ${LOCALBASE}/mpich/lib/libmpich.a:${PORTSDIR}/net/mpich
+BUILD_DEPENDS= ${LOCALBASE}/mpich2/lib/libmpich.a:${PORTSDIR}/net/mpich2
+RUN_DEPENDS= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
@@ -53,8 +55,9 @@ CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops
pre-patch:
(${CP} ${WRKSRC}/BMAKES/Bmake.MPI-LINUX ${WRKSRC}/Bmake.inc)
+
post-patch:
- (${REINPLACE_CMD} -e 's,@WRKSRC@,${WRKSRC},g ; s,@DEBUG_LEVEL@,${DEBUG_LEVEL},g ; s,@PREFIX@,${PREFIX},g ; s,@CC@,${CC},g ; s,@CFLAGS@,${CFLAGS},g ; s,@F77@,${F77},g ; s,@FFLAGS@,${FFLAGS},g ; s,@F77EXTRAFLAGS@,${F77EXTRAFLAGS},g ; s, ARCH *.= ar, ARCMD = ar,' ${WRKSRC}/Bmake.inc)
+ (${REINPLACE_CMD} -e 's,@WRKSRC@,${WRKSRC},g ; s,@DEBUG_LEVEL@,${DEBUG_LEVEL},g ; s,@LOCALBASE@,${LOCALBASE},g ; s,@CC@,${CC},g ; s,@CFLAGS@,${CFLAGS},g ; s,@F77@,${F77},g ; s,@FFLAGS@,${FFLAGS},g ; s,@F77EXTRAFLAGS@,${F77EXTRAFLAGS},g ; s, ARCH *.= ar, ARCMD = ar,' ${WRKSRC}/Bmake.inc)
${REINPLACE_CMD} -e 's|\$$(ARCH)|$$(ARCMD)|' ${WRKSRC}/SRC/MPI/Makefile
do-build:
@@ -83,8 +86,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's,/usr/local,${PREFIX},g' ${FILESDIR}/pkg-message.in \
- > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/math/blacs/files/patch-Bmake.inc b/math/blacs/files/patch-Bmake.inc
index 4c69d97146ed..1b6f547a9a87 100644
--- a/math/blacs/files/patch-Bmake.inc
+++ b/math/blacs/files/patch-Bmake.inc
@@ -31,11 +31,11 @@
# Name and location of the MPI library.
# -------------------------------------
- MPIdir = /usr/local/mpich
-+ MPIdir = @PREFIX@/mpich
++ MPIdir = @LOCALBASE@/mpich2
MPILIBdir = $(MPIdir)/lib/
MPIINCdir = $(MPIdir)/include
- MPILIB = $(MPILIBdir)/libmpich.a
-+ MPILIB = $(MPILIBdir)/libmpich.a $(MPILIBdir)/libpmpich.a
++ MPILIB = $(MPILIBdir)/libmpich.a
# -------------------------------------
# All libraries required by the tester.
diff --git a/math/blacs/files/pkg-message.in b/math/blacs/files/pkg-message.in
index 31b7200a8542..fff4dfef90dc 100644
--- a/math/blacs/files/pkg-message.in
+++ b/math/blacs/files/pkg-message.in
@@ -1,12 +1,14 @@
*********************************************************************
Please test your blacs installation
- Test programs are located at /usr/local/share/BLACS/TESTING
+ Test programs are located at %%PREFIX%%/share/BLACS/TESTING
Example:
- % cd /usr/local/share/BLACS/TESTING
- % /usr/local/mpich/bin/mpirun -np 4 xCbtest_MPI-FreeBSD
- % /usr/local/mpich/bin/mpirun -np 4 xFbtest_MPI-FreeBSD
+ % cd %%PREFIX%%/share/BLACS/TESTING
+ % %%LOCALBASE%%/mpich2/bin/mpd &
+ % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xCbtest_MPI-FreeBSD
+ % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xFbtest_MPI-FreeBSD
+ % %%LOCALBASE%%/mpich2/bin/mpdallexit
You can change -np 4 to any number to meet your local environment.
-See files at /usr/local/share/doc/blacs for detail.
+See files at %%DOCSDIR%% for detail.
*********************************************************************
diff --git a/math/blacs/pkg-message b/math/blacs/pkg-message
index a498cfdbeca0..e69de29bb2d1 100644
--- a/math/blacs/pkg-message
+++ b/math/blacs/pkg-message
@@ -1,12 +0,0 @@
-*********************************************************************
- Please test your blacs installation
- Test programs are located at /usr/local/share/BLACS/TESTING
-
- Example:
- % cd /usr/local/share/BLACS/TESTING
- % mpirun -np 4 xCbtest_MPI-FreeBSD
- % mpirun -np 4 xFbtest_MPI-FreeBSD
-
-You can change -np 4 to any number to meet your local environment.
-See files at /usr/local/share/doc/blacs for detail.
-*********************************************************************