aboutsummaryrefslogtreecommitdiffstats
path: root/math/blas
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-09 20:00:26 +0800
committermaho <maho@FreeBSD.org>2007-01-09 20:00:26 +0800
commit3967ae3c40a6483f8a66810b36c5796fbaae91cc (patch)
tree32647a83388376400b807ff72b27c88ce2bf0570 /math/blas
parentf23710981637c0acfc8bf3f3168b6aba3b25c576 (diff)
downloadfreebsd-ports-gnome-3967ae3c40a6483f8a66810b36c5796fbaae91cc.tar.gz
freebsd-ports-gnome-3967ae3c40a6483f8a66810b36c5796fbaae91cc.tar.zst
freebsd-ports-gnome-3967ae3c40a6483f8a66810b36c5796fbaae91cc.zip
Migrate to gfortran.
Approved by: stas (maintainer)
Diffstat (limited to 'math/blas')
-rw-r--r--math/blas/Makefile7
-rw-r--r--math/blas/files/makefile.lib2
2 files changed, 5 insertions, 4 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index f46220c17651..df5e28e829d9 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -7,6 +7,7 @@
PORTNAME= blas
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://netlib.bell-labs.com/netlib/blas/ \
ftp://ftp.mirrorservice.org/sites/netlib.bell-labs.com/netlib/blas/ \
@@ -21,10 +22,10 @@ CONFLICTS= elmer-mathlibs-1*
USE_LDCONFIG= yes
NO_WRKSUBDIR= yes
-USE_GCC= 2.7+
-WITH_FORTRAN= yes
+WANT_FORTRAN= yes
+USE_GCC= 4.2+
-PLIST_FILES= lib/libblas.a lib/libblas.so lib/libblas.so.1
+PLIST_FILES= lib/libblas.a lib/libblas.so lib/libblas.so.2
do-configure:
@${INSTALL_DATA} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
diff --git a/math/blas/files/makefile.lib b/math/blas/files/makefile.lib
index 607a9fb21df7..99a484141cfc 100644
--- a/math/blas/files/makefile.lib
+++ b/math/blas/files/makefile.lib
@@ -8,7 +8,7 @@ NO_PROFILE= no
NOPROFILE= no
.endif
-SHLIB_MAJOR= 1
+SHLIB_MAJOR= 2
# BLAS sources
LIB=blas