aboutsummaryrefslogtreecommitdiffstats
path: root/math/blas
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>1997-04-03 09:10:59 +0800
committerfenner <fenner@FreeBSD.org>1997-04-03 09:10:59 +0800
commita44baaaee2d4da6c2c5cbf9fb0729f65ff634d58 (patch)
treebd7a0764ba5e5afb07fda1d4b2dd200398e27260 /math/blas
parentaf208ba8a382ca90bcf53b1e28fb6862122b5ae6 (diff)
downloadfreebsd-ports-gnome-a44baaaee2d4da6c2c5cbf9fb0729f65ff634d58.tar.gz
freebsd-ports-gnome-a44baaaee2d4da6c2c5cbf9fb0729f65ff634d58.tar.zst
freebsd-ports-gnome-a44baaaee2d4da6c2c5cbf9fb0729f65ff634d58.zip
Fix MASTER_SITES since netlib.att.com went away. Clean up Makefiles
a little while I'm here.
Diffstat (limited to 'math/blas')
-rw-r--r--math/blas/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 16d0a643480a..cadde69ac1bf 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -3,19 +3,29 @@
# Date created: 27 October 1994
# Whom: ljo
#
-# $Id: Makefile,v 1.9 1996/03/10 09:00:53 asami Exp $
+# $Id: Makefile,v 1.10 1996/11/18 11:31:51 asami Exp $
#
DISTNAME= blas
PKGNAME= blas-1.0
CATEGORIES= math
-MASTER_SITES= ftp://netlib.att.com/netlib/blas/
+MASTER_SITES= ftp://netlib.bell-labs.com/netlib/blas/ \
+ ftp://ftp.netlib.org/blas/
+
+# NOTE:
+# The files [dir]1mach.f were updated on the master site but
+# FreeBSD's f77 can't handle them. patches/patch-aa reverts
+# these files to a previous revision but should be removed when
+# FreeBSD's f77 gets fixed.
+#
+# The alternative is:
+#BROKEN= "Our f77 cannot compile d1mach.f"
DIST_SUBDIR= ${DISTNAME}
-EXTRACT_CMD=${.CURDIR}/scripts/uncomp
-EXTRACT_SUFX=.Z
-EXTRACT_ARGS= ${WRKDIR}
+EXTRACT_CMD= ${SCRIPTDIR}/uncomp
+EXTRACT_SUFX= .Z
+EXTRACT_ARGS= ${WRKDIR}
NO_WRKSUBDIR= yes
@@ -44,7 +54,7 @@ pre-build:
cp Makefile.lib ${WRKDIR}/Makefile
pre-extract:
- chmod +x scripts/uncomp
+ chmod +x ${SCRIPTDIR}/uncomp
post-install:
ldconfig -m ${PREFIX}/lib