aboutsummaryrefslogtreecommitdiffstats
path: root/math/blas
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /math/blas
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'math/blas')
-rw-r--r--math/blas/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 81299401a731..f04d91620d97 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -3,7 +3,7 @@
# Date created: 27 October 1994
# Whom: ljo
#
-# $Id: Makefile,v 1.19 1998/08/09 00:05:49 steve Exp $
+# $Id: Makefile,v 1.20 1998/09/28 09:44:23 asami Exp $
#
DISTNAME= blas
@@ -18,13 +18,15 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}
+.include <bsd.port.pre.mk>
+
pre-build:
${CP} ${FILESDIR}/makefile.lib ${WRKDIR}/Makefile
post-install:
${LDCONFIG} -m ${PREFIX}/lib
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libblas.so.1.0 ${PREFIX}/lib/libblas.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libblas.so.1.0 ${PREFIX}/lib/libblas.so
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>