aboutsummaryrefslogtreecommitdiffstats
path: root/math/ccmath/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-03-21 02:25:10 +0800
committerroam <roam@FreeBSD.org>2001-03-21 02:25:10 +0800
commit99bc1d53959f0c0b793bf6e56ef5dbeb554d8e75 (patch)
tree16c7c04f22fb963bfe83378a1d8e0f5f23d5c056 /math/ccmath/Makefile
parent51e01f3b01fc74a6e8dc8447889175956e30c4dc (diff)
downloadfreebsd-ports-gnome-99bc1d53959f0c0b793bf6e56ef5dbeb554d8e75.tar.gz
freebsd-ports-gnome-99bc1d53959f0c0b793bf6e56ef5dbeb554d8e75.tar.zst
freebsd-ports-gnome-99bc1d53959f0c0b793bf6e56ef5dbeb554d8e75.zip
Add ccmath, a mathematics library with many functions.
PR: 25589 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'math/ccmath/Makefile')
-rw-r--r--math/ccmath/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/math/ccmath/Makefile b/math/ccmath/Makefile
new file mode 100644
index 000000000000..77ad7ca65dcc
--- /dev/null
+++ b/math/ccmath/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ccmath
+# Date created: 07 March 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccmath
+PORTVERSION= 2.2.0
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= libs
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+INSTALLS_SHLIB= yes
+
+post-configure:
+.if (${MACHINE_ARCH} != "i386")
+ (cd ${WRKSRC} && ${SH} non_intel.sh)
+.endif
+
+do-build:
+ (cd ${WRKSRC} && ${SH} makelibs.sh)
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/ccmath.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/tmp/libccm.a ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/tmp/libccm.so ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ccmath
+ ${INSTALL_DATA} ${WRKSRC}/manual/* ${PREFIX}/share/doc/ccmath
+.endif
+
+.include <bsd.port.mk>