aboutsummaryrefslogtreecommitdiffstats
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-10-17 01:00:02 +0800
committerjbeich <jbeich@FreeBSD.org>2016-10-17 01:00:02 +0800
commit888b132e15e7b7adda38da1aabe41333e9da8033 (patch)
treee7c6903c14a4f724b868dbe210b0fed8aad8e602 /math/ceres-solver
parent0fed37dac10fc85036f07378159076b5157a4b72 (diff)
downloadfreebsd-ports-gnome-888b132e15e7b7adda38da1aabe41333e9da8033.tar.gz
freebsd-ports-gnome-888b132e15e7b7adda38da1aabe41333e9da8033.tar.zst
freebsd-ports-gnome-888b132e15e7b7adda38da1aabe41333e9da8033.zip
math/ceres-solver: disable EIGENSPARSE by default like upstream
During configure stage the following =============================================================== Enabling the use of Eigen as a sparse linear algebra library for solving the nonlinear least squares problems. Enabling this option results in an LGPL licensed version of Ceres Solver as the Simplicial Cholesky factorization in Eigen is licensed under the LGPL. =============================================================== turns into =============================================================== Disabling the use of Eigen as a sparse linear algebra library. This does not affect the covariance estimation algorithm which can still use the EIGEN_SPARSE_QR algorithm. ===============================================================
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index b86d826569e7..8bf7b06ef593 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ceres-solver
DISTVERSION= 1.12.0rc1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= jbeich@FreeBSD.org
@@ -28,7 +29,7 @@ PORTDOCS= *
PORTEXAMPLES= *
OPTIONS_DEFINE= CUSTOM_BLAS EXAMPLES DOCS GFLAGS LAPACK OPENMP SCHUR TEST
-OPTIONS_DEFAULT=CUSTOM_BLAS NETLIB OPENMP SCHUR ${OPTIONS_GROUP_SPARSE}
+OPTIONS_DEFAULT=CUSTOM_BLAS CXSPARSE NETLIB OPENMP SCHUR SUITESPARSE
OPTIONS_RADIO= LAPACK
OPTIONS_RADIO_LAPACK= ATLAS GOTOBLAS NETLIB OPENBLAS
OPTIONS_GROUP= SPARSE
@@ -85,8 +86,10 @@ CXSPARSE_DESC= CXSparse support
CXSPARSE_LIB_DEPENDS= libcxsparse.so:math/suitesparse
CXSPARSE_CMAKE_ON= -DCXSPARSE_INCLUDE_DIR="${LOCALBASE}/include/suitesparse"
CXSPARSE_CMAKE_BOOL= CXSPARSE
-EIGENSPARSE_DESC= Eigen support
+EIGENSPARSE_DESC= Simplicial Cholesky factorization in Eigen
EIGENSPARSE_CMAKE_BOOL= EIGENSPARSE
+EIGENSPARSE_VARS= LICENSE+=LGPL21+ LICENSE_COMB=multi \
+ LICENSE_FILE_BSD3CLAUSE="${LICENSE_FILE}"
SUITESPARSE_DESC= SuiteSparse support
SUITESPARSE_LIB_DEPENDS=libspqr.so:math/suitesparse
SUITESPARSE_CMAKE_BOOL= SUITESPARSE