aboutsummaryrefslogtreecommitdiffstats
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-16 04:42:11 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-16 04:42:11 +0800
commitd22149e6e788f5e28c7ba4cb3b78ef6da92d82e6 (patch)
tree0dab8a8018a0b3f190769037a04321aa07bf59b9 /math/ceres-solver
parent123002a5937cad9b1a8ba905d215dde1b25f39f0 (diff)
downloadfreebsd-ports-gnome-d22149e6e788f5e28c7ba4cb3b78ef6da92d82e6.tar.gz
freebsd-ports-gnome-d22149e6e788f5e28c7ba4cb3b78ef6da92d82e6.tar.zst
freebsd-ports-gnome-d22149e6e788f5e28c7ba4cb3b78ef6da92d82e6.zip
math/ceres-solver: unbreak TBB=on
Determining if the include file pthread.h exists failed with the following output: Change Dir: /wrkdirs/usr/ports/math/ceres-solver/work/.build/CMakeFiles/CMakeTmp Run Build Command:"/usr/bin/make" "cmTC_b9506/fast" /usr/bin/make -f CMakeFiles/cmTC_b9506.dir/build.make CMakeFiles/cmTC_b9506.dir/build Building C object CMakeFiles/cmTC_b9506.dir/CheckIncludeFile.c.o /usr/bin/cc -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -std=c++11 -o CMakeFiles/cmTC_b9506.dir/CheckIncludeFile.c.o -c /wrkdirs/usr/ports/math/ceres-solver/work/.build/CMakeFiles/CMakeTmp/CheckIncludeFile.c error: invalid argument '-std=c++11' not allowed with 'C/ObjC' *** Error code 1
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/files/patch-CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/math/ceres-solver/files/patch-CMakeLists.txt b/math/ceres-solver/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d52e30ba0b39
--- /dev/null
+++ b/math/ceres-solver/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+https://github.com/ceres-solver/ceres-solver/issues/355
+
+--- CMakeLists.txt.orig 2018-03-22 04:00:14 UTC
++++ CMakeLists.txt
+@@ -435,7 +435,7 @@ if (CXX11 AND COMPILER_HAS_CXX11_FLAG)
+ # Update CMAKE_REQUIRED_FLAGS used by CheckCXXSourceCompiles to include
+ # -std=c++11 s/t we will detect the C++11 versions of unordered_map &
+ # shared_ptr if they exist.
+- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -std=c++11")
++ set(CMAKE_CXX_STANDARD 11)
+ endif (CXX11 AND COMPILER_HAS_CXX11_FLAG)
+
+ # Set the Ceres compile definitions for the unordered_map configuration.