aboutsummaryrefslogtreecommitdiffstats
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-04-23 01:37:56 +0800
committerKoop Mast <koop@beyonit.nl>2019-04-23 03:03:35 +0800
commitc8fcb108a12a71ea8b308053f301697429855fd0 (patch)
tree8fff6767820eeb7c34fe03d28f96ec174faa6159 /math/ceres-solver
parentb943800e8416bdbc53fd3a97cde34d90461c4130 (diff)
downloadfreebsd-ports-gnome-c8fcb108a12a71ea8b308053f301697429855fd0.tar.gz
freebsd-ports-gnome-c8fcb108a12a71ea8b308053f301697429855fd0.tar.zst
freebsd-ports-gnome-c8fcb108a12a71ea8b308053f301697429855fd0.zip
math/ceres-solver: drop GCC RPATH after r499061
USES=fortran was used to ensure linking against libceres picks up correct libgcc_s to satisfy dependencies e.g., suitesparse, *blas.
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 82962dd90e35..3f6890b50b35 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -68,9 +68,7 @@ TEST_TEST_TARGET= test ARGS="-V"
TEST_IMPLIES= GFLAGS
LAPACK_DESC= Linear Algebra PACKage
-LAPACK_USES= fortran # LDFLAGS
LAPACK_CMAKE_BOOL= LAPACK
-LAPACK_CMAKE_ON= -DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW # USES=fortran
# Avoid conflict with Ceres threading by using single-threaded BLAS library.
# BLASLIB from USES=blaslapack cannot be used as it's multi-threaded.
# https://github.com/xianyi/OpenBLAS/wiki/faq#multi-threaded