aboutsummaryrefslogtreecommitdiffstats
path: root/math/coinmp
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-07-18 03:55:37 +0800
committerpi <pi@FreeBSD.org>2014-07-18 03:55:37 +0800
commit0f80f2ecf4805294a04ecda8b5368e6804b6fbf3 (patch)
treea7d88c514da8dc0f2b56fb1fc5b91041ebf1f41b /math/coinmp
parent5e833b9463dbb5d8718ac17ceea01b3e44b0cf08 (diff)
downloadfreebsd-ports-gnome-0f80f2ecf4805294a04ecda8b5368e6804b6fbf3.tar.gz
freebsd-ports-gnome-0f80f2ecf4805294a04ecda8b5368e6804b6fbf3.tar.zst
freebsd-ports-gnome-0f80f2ecf4805294a04ecda8b5368e6804b6fbf3.zip
math/coinmp: some fixes
- Clean-up Makefile - Fix stage-qa error - Unbreak GLPK option PR: 187487 Submitted by: cjpugmed@gmail.com (maintainer)
Diffstat (limited to 'math/coinmp')
-rw-r--r--math/coinmp/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/math/coinmp/Makefile b/math/coinmp/Makefile
index dde7fa8fcec0..3d647922260f 100644
--- a/math/coinmp/Makefile
+++ b/math/coinmp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= CoinMP
PORTVERSION= 1.7.6
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/CoinMP/
@@ -22,14 +23,15 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CONFIGURE_ARGS+= PKG_CONFIG_PATH=${STAGEDIR}${PREFIX}/libdata/pkgconfig
-OPTIONS_DEFINE= DEBUG DOCS
+OPTIONS_DEFINE= DEBUG DOCS GLPK
+
+GLPK_DESC= GNU Linear Programming Kit support
PORTDOCS= *
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGLPK}
-BROKEN = the GLPK option requires math/glpk headers that are not currently installed by that port
CONFIGURE_ARGS+= --with-gmpl-incdir=${LOCALBASE}/include \
--with-gmpl-lib="-L${LOCALBASE}/lib -lglpk"
LIB_DEPENDS+= libglpk.so:${PORTSDIR}/math/glpk
@@ -43,14 +45,10 @@ CXXFLAGS+= -fomit-frame-pointer
.endif
post-patch::
- @${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/Clp/Makefile.in ${WRKSRC}/Osi/Makefile.in \
- ${WRKSRC}/Cbc/Makefile.in ${WRKSRC}/Cgl/Makefile.in \
- ${WRKSRC}/CoinUtils/Makefile.in ${WRKSRC}/CoinMP/Makefile.in \
- ${WRKSRC}/Data/Sample/Makefile.in
- @${REINPLACE_CMD} -e 's|$$(DESTDIR)$$(addlibsdir)|$$(addlibsdir)|g' \
- ${WRKSRC}/CoinMP/Makefile.in
+ -e 's|$$(DESTDIR)$$(addlibsdir)|$$(addlibsdir)|g' \
+ -e 's|addlibs_DATA = examples/Makefile examples/example.c||g'
post-install:
${MV} ${STAGEDIR}${PREFIX}/share/coin/doc ${STAGEDIR}${DOCSDIR}