aboutsummaryrefslogtreecommitdiffstats
path: root/math/cvcl/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-09-20 09:42:03 +0800
committerijliao <ijliao@FreeBSD.org>2006-09-20 09:42:03 +0800
commitfd91087a8cf266498e91caf1be07b8875aa2377e (patch)
treed52bb541553b3be4cb08b05921ea5e5bac964406 /math/cvcl/Makefile
parent1bebbfea782f9207ef92e2d4b0f960dd22853a83 (diff)
downloadfreebsd-ports-gnome-fd91087a8cf266498e91caf1be07b8875aa2377e.tar.gz
freebsd-ports-gnome-fd91087a8cf266498e91caf1be07b8875aa2377e.tar.zst
freebsd-ports-gnome-fd91087a8cf266498e91caf1be07b8875aa2377e.zip
add cvcl 2.5.1
An automatic theorem prover for the SMT problem PR: 103412 Submitted by: Li-Wen Hsu <lwhsu@lwhsu.org>
Diffstat (limited to 'math/cvcl/Makefile')
-rw-r--r--math/cvcl/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/cvcl/Makefile b/math/cvcl/Makefile
new file mode 100644
index 000000000000..a085838fb9b2
--- /dev/null
+++ b/math/cvcl/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: cvcl
+# Date created: 2006-09-15
+# Whom: Li-wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvcl
+PORTVERSION= 2.5.1
+CATEGORIES= math
+MASTER_SITES= http://www.cs.nyu.edu/acsys/cvcl/download/
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= An automatic theorem prover for the SMT problem
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_GMAKE= yes
+USE_BISON= yes
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-arith=gmp \
+ --with-extra-libs=${LOCALBASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include \
+ --with-build=optimized
+
+WRKSRC= ${WRKDIR}/cvcl-20060527
+
+.include <bsd.port.mk>