aboutsummaryrefslogtreecommitdiffstats
path: root/math/cxsc
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-11-04 12:31:30 +0800
committerleeym <leeym@FreeBSD.org>2004-11-04 12:31:30 +0800
commit86d30600ff0c0af90f964bcf5bd5a081d7266c60 (patch)
tree304a5dca04eaa2b644d90014dd4623521b202a73 /math/cxsc
parent9f019cf952c3d5872a041fd33b70d433969a38bd (diff)
downloadfreebsd-ports-gnome-86d30600ff0c0af90f964bcf5bd5a081d7266c60.tar.gz
freebsd-ports-gnome-86d30600ff0c0af90f964bcf5bd5a081d7266c60.tar.zst
freebsd-ports-gnome-86d30600ff0c0af90f964bcf5bd5a081d7266c60.zip
- add USE_GCC=3.3 when default gcc is 3.4
- utilize BSD_INSTALL_DATA in INSTALL_MACROS
Diffstat (limited to 'math/cxsc')
-rw-r--r--math/cxsc/Makefile3
-rw-r--r--math/cxsc/files/patch-Makefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/math/cxsc/Makefile b/math/cxsc/Makefile
index c672806aca76..d29db569f11d 100644
--- a/math/cxsc/Makefile
+++ b/math/cxsc/Makefile
@@ -18,12 +18,11 @@ COMMENT= C++ class library for eXtended Scientific Computing
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
-MAKE_ENV= INSTALL_DATA="${INSTALL_DATA}"
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
+USE_GCC= 3.3
.endif
.include <bsd.port.post.mk>
diff --git a/math/cxsc/files/patch-Makefile b/math/cxsc/files/patch-Makefile
index 2eee7a257a99..240f1aa4d6ff 100644
--- a/math/cxsc/files/patch-Makefile
+++ b/math/cxsc/files/patch-Makefile
@@ -29,7 +29,7 @@
export RMDIR=rm -rf# remove directory
-export INSTALL=install -m 644# copy files
-+export INSTALL=${INSTALL_DATA}# copy files
++export INSTALL=${BSD_INSTALL_DATA}# copy files
export STRIP=strip -g# strip executables from debug symbols
export INSTDIR=install -d# create installation directory