aboutsummaryrefslogtreecommitdiffstats
path: root/math/drgeo/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-11 16:35:25 +0800
committermarcus <marcus@FreeBSD.org>2003-01-11 16:35:25 +0800
commit7a4b56a0718e83f2cb50c583e67d8cce84310e59 (patch)
tree95c5d4ef6cd048c70e85fb857daef59425f1901d /math/drgeo/Makefile
parentfc70f5d6c1bd7a430281690c6a8bad5c24f0c077 (diff)
downloadfreebsd-ports-gnome-7a4b56a0718e83f2cb50c583e67d8cce84310e59.tar.gz
freebsd-ports-gnome-7a4b56a0718e83f2cb50c583e67d8cce84310e59.tar.zst
freebsd-ports-gnome-7a4b56a0718e83f2cb50c583e67d8cce84310e59.zip
Add drgenius, a geometry exploration application built on top of GNOME.
Requested by: P. U. Kruppa <520023893678-0001@t-online.de>
Diffstat (limited to 'math/drgeo/Makefile')
-rw-r--r--math/drgeo/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/drgeo/Makefile b/math/drgeo/Makefile
new file mode 100644
index 000000000000..7a2d0b280c5b
--- /dev/null
+++ b/math/drgeo/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: drgenius
+# Date created: 11 January 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drgenius
+PORTVERSION= 0.8.0
+CATEGORIES= math
+MASTER_SITES= http://www.ofset.org/drgenius/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= gob:${PORTSDIR}/x11-toolkits/gob
+LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libglade
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>