aboutsummaryrefslogtreecommitdiffstats
path: root/math/dynare
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-01-19 20:29:37 +0800
committerdanilo <danilo@FreeBSD.org>2014-01-19 20:29:37 +0800
commitdd8bc8fe8470f223669a5553585f52bd4e3467da (patch)
tree2509fe397ea3484fcce6fdfddd1f4e6880c8e4ff /math/dynare
parentceea2f4d29016623d92b2a2fcacd58e276249974 (diff)
downloadfreebsd-ports-gnome-dd8bc8fe8470f223669a5553585f52bd4e3467da.tar.gz
freebsd-ports-gnome-dd8bc8fe8470f223669a5553585f52bd4e3467da.tar.zst
freebsd-ports-gnome-dd8bc8fe8470f223669a5553585f52bd4e3467da.zip
- Update from 4.3.3 to 4.4.0
- Add stage support while here - Convert USE_GMAKE to USES - Use options helpers PR: ports/185783 Submitted by: Fernando <fernando.apesteguia@gmail.com> (maintainer)
Diffstat (limited to 'math/dynare')
-rw-r--r--math/dynare/Makefile28
-rw-r--r--math/dynare/distinfo4
-rw-r--r--math/dynare/files/patch-configure11
-rw-r--r--math/dynare/files/patch-configure.ac27
4 files changed, 50 insertions, 20 deletions
diff --git a/math/dynare/Makefile b/math/dynare/Makefile
index a9e0821ee94f..7544efd1c534 100644
--- a/math/dynare/Makefile
+++ b/math/dynare/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dynare
-PORTVERSION= 4.3.3
-PORTREVISION= 1
+PORTVERSION= 4.4.0
CATEGORIES= math
MASTER_SITES= http://www.dynare.org/release/source/
@@ -11,32 +10,25 @@ MAINTAINER= fernando.apesteguia@gmail.com
COMMENT= Software platform for handling a wide class of economic models
BUILD_DEPENDS= ${LOCALBASE}/include/boost/unordered_set.hpp:${PORTSDIR}/devel/boost-libs
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libumfpack.so:${PORTSDIR}/math/suitesparse
+BUILD_DEPENDS+= ${LOCALBASE}/include/matio.h:${PORTSDIR}/math/matio
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_FORTRAN= yes
USE_XZ= yes
INFO= dynare
-OPTIONS_DEFINE= OCTAVE MATLAB
-OCTAVE_DESC=Enable compilation of MEX files for Octave
-MATLAB_DESC= Enable compilation of MEX files for MATLAB
+OPTIONS_DEFINE= OCTAVE MATLAB
+OCTAVE_DESC= Enable compilation of MEX files for Octave
+MATLAB_DESC= Enable compilation of MEX files for MATLAB
OPTIONS_DEFAULT= OCTAVE
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MMATLAB)
-CONFIGURE_ARGS+= --disable-matlab
-.endif
-
-.if ${PORT_OPTIONS:MOCTAVE}
-BUILD_DEPENDS+= octave:${PORTSDIR}/math/octave
-.else
-CONFIGURE_ARGS+= --disable-octave
-.endif
+MATLAB_CONFIGURE_ENABLE= matlab
+OCTAVE_CONFIGURE_ENABLE= octave
+OCTAVE_BUILD_DEPENDS= octave:${PORTSDIR}/math/octave
post-configure:
@${ECHO_MSG} ""
diff --git a/math/dynare/distinfo b/math/dynare/distinfo
index 3d8a88bb1f60..c2043b314ac6 100644
--- a/math/dynare/distinfo
+++ b/math/dynare/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dynare-4.3.3.tar.xz) = 76c9ca44ed95d63f2b3a565dd8e91f5e6c51265dd1c75a5d80125eaac812f1d0
-SIZE (dynare-4.3.3.tar.xz) = 12430124
+SHA256 (dynare-4.4.0.tar.xz) = b6cd4ad5204d53ccfce4e463c3138a2059803fbae8670f44d79740616caa92fe
+SIZE (dynare-4.4.0.tar.xz) = 14897624
diff --git a/math/dynare/files/patch-configure b/math/dynare/files/patch-configure
new file mode 100644
index 000000000000..92c99caf0559
--- /dev/null
+++ b/math/dynare/files/patch-configure
@@ -0,0 +1,11 @@
+--- mex/build/octave/configure.orig 2014-01-10 20:33:42.000000000 +0100
++++ mex/build/octave/configure 2014-01-10 20:34:24.000000000 +0100
+@@ -6769,7 +6769,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lumfpack $LIBS"
++LIBS="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
diff --git a/math/dynare/files/patch-configure.ac b/math/dynare/files/patch-configure.ac
new file mode 100644
index 000000000000..e1336c88135b
--- /dev/null
+++ b/math/dynare/files/patch-configure.ac
@@ -0,0 +1,27 @@
+--- mex/build/octave/configure.ac.orig 2013-12-06 14:52:59.682612000 +0100
++++ mex/build/octave/configure.ac 2014-01-10 20:59:19.000000000 +0100
+@@ -36,6 +36,7 @@
+ CFLAGS="$CFLAGS -Wall -Wno-parentheses"
+ FFLAGS="$FFLAGS -Wall"
+ CXXFLAGS="$CXXFLAGS -Wall -Wno-parentheses"
++LIBS="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd"
+
+ AC_PROG_F77([gfortran g77 f77])
+ AC_PROG_CC
+@@ -61,14 +62,10 @@
+ AM_CONDITIONAL([HAVE_SLICOT], [test "x$has_slicot" = "xyes"])
+
+ # Check for UMFPACK, needed by bytecode
+-AC_CHECK_LIB([umfpack], [umfpack_dl_defaults], [LIBADD_UMFPACK="-lumfpack"], [AC_MSG_ERROR([Can't find UMFPACK])])
++AC_CHECK_LIB([umfpack], [umfpack_dl_defaults], [LIBADD_UMFPACK="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd"], [AC_MSG_ERROR([Can't find UMFPACK])])
+ # For OS X, explicitly add libraries that libumfpack depends on as Homebrew
+ # doesn't support the creation of shared libraries for suite-sparse 3.7.0
+-case ${host_os} in
+- darwin*)
+- LIBADD_UMFPACK="-lumfpack -lcholmod -lcolamd -lamd"
+- ;;
+-esac
++LIBADD_UMFPACK="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd"
+ AC_SUBST([LIBADD_UMFPACK])
+
+ AM_CONDITIONAL([DO_SOMETHING], [test "x$MKOCTFILE" != "x"])