aboutsummaryrefslogtreecommitdiffstats
path: root/math/eigen/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
committermiwi <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
commitc486a60f04933c8227640b8faca0f931afbe32ef (patch)
tree827b6cdb889eaa1ccc00ca4598ae40dee1a42a50 /math/eigen/Makefile
parent888eabb1977d6504355090d942963975c8d755ed (diff)
downloadfreebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.tar.gz
freebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.tar.zst
freebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.zip
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Diffstat (limited to 'math/eigen/Makefile')
-rw-r--r--math/eigen/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/math/eigen/Makefile b/math/eigen/Makefile
index aa602cac18ba..be26db571c7b 100644
--- a/math/eigen/Makefile
+++ b/math/eigen/Makefile
@@ -12,22 +12,11 @@ MASTER_SITES= http://download.tuxfamily.org/eigen/
MAINTAINER= kde@FreeBSD.org
COMMENT= Lightweight library for vector and matrix math
-BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
-
-CMAKE?= ${LOCALBASE}/bin/cmake
+USE_CMAKE= yes
+CMAKE_SOURCE_PATH= ..
WRKSRC= ${WRKDIR}/${PORTNAME}/build
-MAKE_ENV= VERBOSE="1"
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
- -DCMAKE_INSTALL_PREFIX=${PREFIX} \
- -DCMAKE_C_COMPILER:STRING='${CC}' \
- -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
- -DCMAKE_CXX_COMPILER:STRING=${CXX} \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
post-patch:
${MKDIR} ${WRKSRC}
-do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
-
.include <bsd.port.mk>