aboutsummaryrefslogtreecommitdiffstats
path: root/math/eigen3/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2008-02-10 05:59:20 +0800
committerarved <arved@FreeBSD.org>2008-02-10 05:59:20 +0800
commit50038f25531588ad9317100df4d4c83c08ade2c3 (patch)
tree42aafba5e6b20d04d4c5d3c8b6ecc56bddc7d6af /math/eigen3/Makefile
parentecb0d375279a9b92d53a1c09c96ac42216cbb29d (diff)
downloadfreebsd-ports-gnome-50038f25531588ad9317100df4d4c83c08ade2c3.tar.gz
freebsd-ports-gnome-50038f25531588ad9317100df4d4c83c08ade2c3.tar.zst
freebsd-ports-gnome-50038f25531588ad9317100df4d4c83c08ade2c3.zip
Add Eigen a lightweight C++ template library for vector and matrix math
Diffstat (limited to 'math/eigen3/Makefile')
-rw-r--r--math/eigen3/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/eigen3/Makefile b/math/eigen3/Makefile
new file mode 100644
index 000000000000..aa602cac18ba
--- /dev/null
+++ b/math/eigen3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: eigen
+# Date created: 2008-01-18
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= eigen
+PORTVERSION= 1.0.5
+CATEGORIES= math
+MASTER_SITES= http://download.tuxfamily.org/eigen/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Lightweight library for vector and matrix math
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+CMAKE?= ${LOCALBASE}/bin/cmake
+WRKSRC= ${WRKDIR}/${PORTNAME}/build
+MAKE_ENV= VERBOSE="1"
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX} \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+
+post-patch:
+ ${MKDIR} ${WRKSRC}
+
+do-configure:
+ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
+
+.include <bsd.port.mk>