aboutsummaryrefslogtreecommitdiffstats
path: root/math/eispack
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-16 12:28:50 +0800
committermaho <maho@FreeBSD.org>2007-01-16 12:28:50 +0800
commit7efeee64c4ecf81e7caf63f5ae56781406e6ec57 (patch)
treef02860592dc66976efa481fe142e59301a53d335 /math/eispack
parent25f74f8ba53d99cc32801daf112402cd95aba4ca (diff)
downloadfreebsd-ports-gnome-7efeee64c4ecf81e7caf63f5ae56781406e6ec57.tar.gz
freebsd-ports-gnome-7efeee64c4ecf81e7caf63f5ae56781406e6ec57.tar.zst
freebsd-ports-gnome-7efeee64c4ecf81e7caf63f5ae56781406e6ec57.zip
* Migrate to gfortran.
* Bump port revision. * Fix build [1]. Submitted by: kris [1]
Diffstat (limited to 'math/eispack')
-rw-r--r--math/eispack/Makefile9
-rw-r--r--math/eispack/files/Makefile.lib4
2 files changed, 9 insertions, 4 deletions
diff --git a/math/eispack/Makefile b/math/eispack/Makefile
index 0e6bb8419b2f..cdca9e1e793f 100644
--- a/math/eispack/Makefile
+++ b/math/eispack/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eispack
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://netlib.bell-labs.com/netlib/eispack/ \
ftp://ftp.mirrorservice.org/sites/netlib.bell-labs.com/netlib/eispack/
@@ -15,12 +16,16 @@ DISTFILES= ${SRCS:.f=.f.gz}
MAINTAINER= ports@FreeBSD.org
COMMENT= Eigenvalue system package
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
-
DIST_SUBDIR= ${PORTNAME}
USE_LDCONFIG= yes
NO_WRKSUBDIR= yes
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+MAKE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+
SRCS = csroot.f epslon.f pythag.f bakvec.f balanc.f balbak.f bandr.f \
bandv.f bisect.f bqr.f cbabk2.f cbal.f cg.f ch.f cinvit.f combak.f \
comhes.f comlr.f comlr2.f comqr.f comqr2.f cortb.f corth.f elmbak.f \
diff --git a/math/eispack/files/Makefile.lib b/math/eispack/files/Makefile.lib
index 047bb86ebac4..b114a04e6325 100644
--- a/math/eispack/files/Makefile.lib
+++ b/math/eispack/files/Makefile.lib
@@ -1,8 +1,8 @@
# EISPACK sources
LIBDIR= ${PREFIX}/lib
-NOPROFILE= no
+NO_PROFILE= no
-SHLIB_MAJOR= 1
+SHLIB_MAJOR= 2
# removed otqlrat.f from the SRCS list, only one tqlrat routine can
# be used in a library.