aboutsummaryrefslogtreecommitdiffstats
path: root/math/eispack
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
committerasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
commitd21b71cc5a3e11bccc9aa5fe5763254cd565d9a5 (patch)
tree560e7eb8a07c987120c853aef90742f320b09b93 /math/eispack
parent8d54bac5baa3871cb4702456e31c93aedc116bd5 (diff)
downloadfreebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.gz
freebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.zst
freebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.zip
Add
post-install: pkg_add -m ${PREFIX}/lib to Makefiles and @exec ldconfig -m %D to packing lists of ports that install shared libraries. This should get rid of a huge chunk of confusion for novice users! All hail Paul Kranenburg! :)
Diffstat (limited to 'math/eispack')
-rw-r--r--math/eispack/Makefile5
-rw-r--r--math/eispack/pkg-plist1
2 files changed, 5 insertions, 1 deletions
diff --git a/math/eispack/Makefile b/math/eispack/Makefile
index 7d5f50ddd368..25b90abe9207 100644
--- a/math/eispack/Makefile
+++ b/math/eispack/Makefile
@@ -3,7 +3,7 @@
# Date created: 31 October 1994
# Whom: ljo
#
-# $Id: Makefile,v 1.6 1995/04/22 11:30:05 asami Exp $
+# $Id: Makefile,v 1.7 1995/04/28 13:35:32 jkh Exp $
#
DISTNAME= eispack
@@ -43,4 +43,7 @@ pre-build:
pre-extract:
chmod +x scripts/uncomp
+post-install:
+ ldconfig -m ${PREFIX}/lib
+
.include <bsd.port.mk>
diff --git a/math/eispack/pkg-plist b/math/eispack/pkg-plist
index e856a99634ce..336c5babed26 100644
--- a/math/eispack/pkg-plist
+++ b/math/eispack/pkg-plist
@@ -1,3 +1,4 @@
@cwd /usr/local
lib/libeispack.a
lib/libeispack.so.1.0
+@exec ldconfig -m %B