aboutsummaryrefslogtreecommitdiffstats
path: root/math/eispack
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /math/eispack
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'math/eispack')
-rw-r--r--math/eispack/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/eispack/Makefile b/math/eispack/Makefile
index a74a17eff0f7..b2f5d92c0ae2 100644
--- a/math/eispack/Makefile
+++ b/math/eispack/Makefile
@@ -3,7 +3,7 @@
# Date created: 31 October 1994
# Whom: ljo
#
-# $Id: Makefile,v 1.16 1998/09/28 10:49:21 asami Exp $
+# $Id: Makefile,v 1.17 1998/11/07 18:31:13 fenner Exp $
#
DISTNAME= eispack
@@ -36,6 +36,8 @@ SRCS = csroot.f epslon.f pythag.f bakvec.f balanc.f balbak.f bandr.f \
DISTFILES= ${SRCS:.f=.f.gz}
+.include <bsd.port.pre.mk>
+
pre-build:
cp Makefile.lib ${WRKDIR}/Makefile
@@ -44,8 +46,8 @@ pre-extract:
post-install:
${LDCONFIG} -m ${PREFIX}/lib
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libeispack.so.1.0 ${PREFIX}/lib/libeispack.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libeispack.so.1.0 ${PREFIX}/lib/libeispack.so
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>