aboutsummaryrefslogtreecommitdiffstats
path: root/math/eukleides
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-04-20 16:45:51 +0800
committerwen <wen@FreeBSD.org>2010-04-20 16:45:51 +0800
commit0a37101a62c41d68b77a229d4a135703651b0100 (patch)
treeb389a698769252acb61ea72ae5e34a00af1890b8 /math/eukleides
parentea9872facf47ec86979303482369d4318093eaf4 (diff)
downloadfreebsd-ports-gnome-0a37101a62c41d68b77a229d4a135703651b0100.tar.gz
freebsd-ports-gnome-0a37101a62c41d68b77a229d4a135703651b0100.tar.zst
freebsd-ports-gnome-0a37101a62c41d68b77a229d4a135703651b0100.zip
- Fix the build error reported bt QAT@
PR: ports/145853 Submitted by: Ashish SHUKLA <wahjava@gmail.com> (maintainer)
Diffstat (limited to 'math/eukleides')
-rw-r--r--math/eukleides/Makefile12
-rw-r--r--math/eukleides/files/patch-build_Makefile~20
2 files changed, 11 insertions, 21 deletions
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 5e7948052720..f58b2ff3d1a9 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -8,6 +8,7 @@
PORTNAME= eukleides
PORTVERSION= 1.5.3
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.eukleides.org/files/
@@ -25,7 +26,6 @@ USE_GETTEXT= yes
USE_ICONV= yes
MAN1= eukleides.1 euktoeps.1 euktopdf.1 euktopst.1 euktotex.1
-PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
.ifndef NOPORTDOCS
BUILD_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base
@@ -33,6 +33,10 @@ PORTDOCS= de.pdf fr.pdf
INFO= eukleides
.endif
+.ifndef NOPORTEXAMPLES
+PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
+.endif
+
post-patch:
${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|#!/bin/bash|#!/bin/sh|g'
@@ -48,8 +52,14 @@ post-patch:
-e '/^all:/ s/doc//g' ${WRKSRC}/Makefile
.endif
+.ifdef NOPORTEXAMPLES
+ ${REINPLACE_CMD} -e 's/install_exm$$//g' ${WRKSRC}/Makefile
+.endif
+
pre-install:
+.ifndef NOPORTEXAMPLES
${MKDIR} ${EXAMPLESDIR}
+.endif
post-install:
for i in euktoeps euktopdf euktotex; do \
diff --git a/math/eukleides/files/patch-build_Makefile~ b/math/eukleides/files/patch-build_Makefile~
deleted file mode 100644
index 12e3ccf9534f..000000000000
--- a/math/eukleides/files/patch-build_Makefile~
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- build/Makefile.orig
-+++ build/Makefile
-@@ -12,12 +12,12 @@
- YACC = bison
- YFLAGS = -d
- CC = gcc
--IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR)
-+IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR) "-I%%LOCALBASE%%/../include" "-I%%LOCALBASE%%/include"
- ifneq ($(strip $(LOCALES)),)
- MOFLAGS = -DMO_DIR=\"$(MO_DIR)\"
- endif
- CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
--LDFLAGS = -lncurses -lreadline -lm
-+LDFLAGS = -lncurses -lreadline -lm "-L%%LOCALBASE%%/lib" -lintl
- VPATH = $(COMMON_DIR):$(MAIN_DIR):$(BUILD_DIR)
-
- $(BINARY):