aboutsummaryrefslogtreecommitdiffstats
path: root/math/fbm/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-07-12 11:59:57 +0800
committermaho <maho@FreeBSD.org>2003-07-12 11:59:57 +0800
commit51b7c8f2f5fa7a42ee26d30f93be2ce31b5adcc8 (patch)
tree772d040d1880af14fe8b1902b3e2ce4479cd04da /math/fbm/Makefile
parent124775f030a233523c5083afc39c7fdbf35cc33f (diff)
downloadfreebsd-ports-gnome-51b7c8f2f5fa7a42ee26d30f93be2ce31b5adcc8.tar.gz
freebsd-ports-gnome-51b7c8f2f5fa7a42ee26d30f93be2ce31b5adcc8.tar.zst
freebsd-ports-gnome-51b7c8f2f5fa7a42ee26d30f93be2ce31b5adcc8.zip
Add new port math/fbm.
A software for Flexible Bayesian Modelling and Markov Chain Sampling(The software is for education and research use only). PR: 53650 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
Diffstat (limited to 'math/fbm/Makefile')
-rw-r--r--math/fbm/Makefile68
1 files changed, 68 insertions, 0 deletions
diff --git a/math/fbm/Makefile b/math/fbm/Makefile
new file mode 100644
index 000000000000..d73b593a07e4
--- /dev/null
+++ b/math/fbm/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: fbm
+# Date created: 31 June 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fbm
+PORTVERSION= 20010803
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.cs.utoronto.ca/pub/radford/
+DISTNAME= ${PORTNAME}.2001-08-31
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Flexible Bayesian Modeling and Markov Chain Sampling
+
+NO_CDROM= 'Free for educational use and research'
+
+USE_REINPLACE= yes
+
+SCRIPTS = bvg-circ bvg-wrap dist-circ dist-wrap gp-circ \
+ gp-wrap mix-circ mix-wrap net-circ net-wrap
+PROGRAMS = bvg-grad-test bvg-hist bvg-initial bvg-mc \
+ bvg-plt bvg-spec bvg-stepsizes bvg-tbl calc \
+ combine data-spec dist-display dist-est \
+ dist-gen dist-genp dist-grad-test dist-hist \
+ dist-initial dist-mc dist-plt dist-spec \
+ dist-stepsizes dist-tbl extract find-min \
+ gp-cov gp-display gp-eigen gp-eval gp-gen \
+ gp-genp gp-grad-test gp-hist gp-mc gp-plt \
+ gp-pred gp-spec gp-stepsizes gp-tbl grid \
+ log-append log-copy log-equal log-last \
+ log-records mc-ais mc-spec mc-temp-filter \
+ mc-temp-sched mix-cases mix-display mix-gen \
+ mix-hist mix-mc mix-plt mix-spec mix-tbl \
+ model-spec net-display net-dvar net-eval \
+ net-gd net-gen net-genp net-grad-test net-hist \
+ net-mc net-plt net-pred net-rej net-spec \
+ net-stepsizes net-tbl rand-seed series
+TEXT= mix-genp
+
+post-patch:
+ @${REINPLACE_CMD} -e 's+%%CC%%+${CC}+g;' ${WRKSRC}/make.include
+ @${REINPLACE_CMD} -e 's+%%CFLAGS%%+${CFLAGS}+g;' ${WRKSRC}/make.include
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} make-all)
+
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} install-arch)
+.for i in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin.${ARCH}/${i} ${PREFIX}/bin
+.endfor
+.for i in ${PROGRAMS}
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin.${ARCH}/${i} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${PREFIX}/share/fbm
+ @${INSTALL_DATA} ${WRKSRC}/util/randfile ${PREFIX}/share/fbm
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R $(WRKSRC)/doc/* ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/html
+ @${MV} ${DOCSDIR}/*.html ${DOCSDIR}/html
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R $(WRKSRC)/ex-* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>