aboutsummaryrefslogtreecommitdiffstats
path: root/math/fftw3/Makefile
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-09-02 02:00:04 +0800
committerahze <ahze@FreeBSD.org>2005-09-02 02:00:04 +0800
commit788b93a5517b1413d7462856c129467884db1c92 (patch)
tree923f39f0b8912743a4cd7065229a0d6ab6b89589 /math/fftw3/Makefile
parent8972dd4348681671b208345fd5f9ddf858a5c525 (diff)
downloadfreebsd-ports-gnome-788b93a5517b1413d7462856c129467884db1c92.tar.gz
freebsd-ports-gnome-788b93a5517b1413d7462856c129467884db1c92.tar.zst
freebsd-ports-gnome-788b93a5517b1413d7462856c129467884db1c92.zip
- Remove -malign-double from WITH_OPTIMIZED_CFLAGS on amd64 to fix build
PR: ports/85555 Submitted by: Tetsuya Uemura
Diffstat (limited to 'math/fftw3/Makefile')
-rw-r--r--math/fftw3/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 7862b7cbdfe1..2b70bea455d5 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -63,9 +63,12 @@ USE_GCC= 3.4
.endif
.if ${MACHINE_CPU:M3dnow}
CONFIGURE_ARGS+=--enable-k7
-CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O3 -fomit-frame-pointer -fno-schedule-insns \
- -malign-double -fstrict-aliasing -mpreferred-stack-boundary=4 \
- -ffast-math"
+CFLAGS_3DNOW= ${CFLAGS:N-O:N-O*} -O3 -fomit-frame-pointer -fno-schedule-insns \
+ -fstrict-aliasing -mpreferred-stack-boundary=4 -ffast-math
+.if ${ARCH} != "amd64"
+CFLAGS_3DNOW+= -malign-double
+.endif
+CONFIGURE_ENV+= CFLAGS="${CFLAGS_3DNOW}"
.endif
.endif # end WITH_OPTIMIZED_CFLAGS