aboutsummaryrefslogtreecommitdiffstats
path: root/math/fftw3
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-06-09 06:38:32 +0800
committerbf <bf@FreeBSD.org>2012-06-09 06:38:32 +0800
commitf9faef2cf3faf101c836d31e9d83de2937b3cfc8 (patch)
treea15867087a2717f61193eb0950685c1cac49bc9e /math/fftw3
parente542d96559465b5539bab9aeea2ce2d672b59dc6 (diff)
downloadfreebsd-ports-gnome-f9faef2cf3faf101c836d31e9d83de2937b3cfc8.tar.gz
freebsd-ports-gnome-f9faef2cf3faf101c836d31e9d83de2937b3cfc8.tar.zst
freebsd-ports-gnome-f9faef2cf3faf101c836d31e9d83de2937b3cfc8.zip
exit earlier, and with a more helpful error message, when attempting to
build the OpenMP libraries with clang [1]; shorten a long line PR: 168804 [1]
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 66992e12fb74..9f2a55838a47 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -34,8 +34,8 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
MAN1= fftw-wisdom-to-conf.1 fftw-wisdom.1
INFO= fftw3
.else
-#For non-default flavors, only build and install the flavor-dependent components,
-#so that these flavors may coexist with the default flavor
+#For non-default flavors, build and install the flavor-dependent components
+#only, so that these flavors may coexist with the default flavor
MAN1= fftw${FFTW3_SUFX}-wisdom.1
INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
.endif
@@ -50,6 +50,10 @@ OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MOPENMP}
+.if !empty(CC:T:M*clang*)
+IGNORE = : clang does not support OpenMP. Disable the OPENMP option or\
+use another compiler
+.endif
CONFIGURE_ARGS+= --enable-openmp
PLIST_SUB+= OPENMP=""
.else