aboutsummaryrefslogtreecommitdiffstats
path: root/math/fftw3
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-12-10 05:58:18 +0800
committerahze <ahze@FreeBSD.org>2004-12-10 05:58:18 +0800
commitb43e58924fa4b4610f60ea6c3654cd8d06b6ee54 (patch)
treefc0efc82cbca315a0b295a985d620777449a3624 /math/fftw3
parent325c5d3979f58d30921ac6f1f4408a563fd4406b (diff)
downloadfreebsd-ports-gnome-b43e58924fa4b4610f60ea6c3654cd8d06b6ee54.tar.gz
freebsd-ports-gnome-b43e58924fa4b4610f60ea6c3654cd8d06b6ee54.tar.zst
freebsd-ports-gnome-b43e58924fa4b4610f60ea6c3654cd8d06b6ee54.zip
Remove WITH_OPTIMIZED_ATHLON knob and auto-detect 3dnow to enable Athlon/3dnow
optimizations Pointed out by: kris
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 04ab626d681d..dd7b2510c054 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -44,17 +44,16 @@ INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off \
SMP_THREADS "Enable FFTW SMP threads library" off \
- OPTIMIZED_ATHLON "Enable AMD Athlon/3dNow! optimizations" off \
SSE "Enable SSE optimized routines" off
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITH_OPTIMIZED_ATHLON)
+.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O2 -ffast-math -fomit-frame-pointer"
.endif
.if ${ARCH}=="i386"
-.if defined(WITH_OPTIMIZED_ATHLON)
+.if ${MACHINE_CPU:M3dnow}
CONFIGURE_ARGS+=--enable-k7
CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O3 -fomit-frame-pointer -fno-schedule-insns \
-malign-double -fstrict-aliasing -mpreferred-stack-boundary=4 \