aboutsummaryrefslogtreecommitdiffstats
path: root/math/foma/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-05-07 22:34:24 +0800
committerdemon <demon@FreeBSD.org>2014-05-07 22:34:24 +0800
commit965ec3fe369dca5ff9e82c518be29ad8da483b9a (patch)
tree37281532f9a62777c8c3cbe1006101508ef26f0b /math/foma/Makefile
parent9878c843530610c9daf8df4598d74460b60f004e (diff)
downloadfreebsd-ports-gnome-965ec3fe369dca5ff9e82c518be29ad8da483b9a.tar.gz
freebsd-ports-gnome-965ec3fe369dca5ff9e82c518be29ad8da483b9a.tar.zst
freebsd-ports-gnome-965ec3fe369dca5ff9e82c518be29ad8da483b9a.zip
New port: foma.
Foma is a compiler, programming language, and C library for constructing finite-state automata and transducers for various uses. It has specific support for many natural language processing applications such as producing morphological analyzers. Although NLP applications are probably the main use of foma, it is sufficiently generic to use for a large number of purposes.
Diffstat (limited to 'math/foma/Makefile')
-rw-r--r--math/foma/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/foma/Makefile b/math/foma/Makefile
new file mode 100644
index 000000000000..215d021c54f3
--- /dev/null
+++ b/math/foma/Makefile
@@ -0,0 +1,25 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= foma
+PORTVERSION= 0.9.17
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A toolkit for constructing finite-state automata and transducers
+
+LICENSE= GPLv2
+
+USES= gmake
+USE_GCC= yes
+USE_LDCONFIG= yes
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_LIB} ${WRKSRC}/libfoma.a ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_LIB} ${WRKSRC}/libfoma.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfoma.so.0
+ cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so
+
+.include <bsd.port.mk>