aboutsummaryrefslogtreecommitdiffstats
path: root/math/foma
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 06:44:10 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 06:44:10 +0800
commit859f972081b6414c6d0614b49baf4fede8346279 (patch)
treec869a0114a90ef3f64176b2d479cb822b6afd8c3 /math/foma
parent8bb03795cb0104a4276ddfb89f89080ada2630e6 (diff)
downloadfreebsd-ports-gnome-859f972081b6414c6d0614b49baf4fede8346279.tar.gz
freebsd-ports-gnome-859f972081b6414c6d0614b49baf4fede8346279.tar.zst
freebsd-ports-gnome-859f972081b6414c6d0614b49baf4fede8346279.zip
Add USES=readline to fix build on current.
Diffstat (limited to 'math/foma')
-rw-r--r--math/foma/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/foma/Makefile b/math/foma/Makefile
index 516215b2993d..4da3c91753fd 100644
--- a/math/foma/Makefile
+++ b/math/foma/Makefile
@@ -11,14 +11,14 @@ COMMENT= Toolkit for constructing finite-state automata and transducers
LICENSE= GPLv2
-USES= bison gmake
+USES= bison gmake readline
USE_LDCONFIG= yes
do-install:
- cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/
- cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/
+ (cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/)
${INSTALL_LIB} ${WRKSRC}/libfoma.a ${STAGEDIR}${PREFIX}/lib/
${INSTALL_LIB} ${WRKSRC}/libfoma.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfoma.so.0
- cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so
+ (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so)
.include <bsd.port.mk>