aboutsummaryrefslogtreecommitdiffstats
path: root/math/gambit/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-12-18 18:37:15 +0800
committerlawrance <lawrance@FreeBSD.org>2005-12-18 18:37:15 +0800
commitb2f9fac4a2630fd8072413a393c300f52ff6cbe7 (patch)
treeaf3b3cdcf58514ac7a75bb4d73efbfd99b49d16b /math/gambit/Makefile
parent8bd6a2ee0bed8de44a7810292971c24a6aefe21a (diff)
downloadfreebsd-ports-gnome-b2f9fac4a2630fd8072413a393c300f52ff6cbe7.tar.gz
freebsd-ports-gnome-b2f9fac4a2630fd8072413a393c300f52ff6cbe7.tar.zst
freebsd-ports-gnome-b2f9fac4a2630fd8072413a393c300f52ff6cbe7.zip
Update to 0.2005.12.12
PR: ports/90556 Submitted by: Ports Fury
Diffstat (limited to 'math/gambit/Makefile')
-rw-r--r--math/gambit/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 619aeae24c82..805671506169 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gambit
-PORTVERSION= 0.2005.06.13
-PORTREVISION= 1
+PORTVERSION= 0.2005.12.12
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,12 +19,20 @@ LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
USE_X_PREFIX= yes
USE_GNOME= gnometarget gtk20
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
MAKE_ENV= WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
+INSTALLS_SHLIB= yes
CPPFLAGS= ${PTHREAD_CFLAGS}
LDFLAGS= ${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
+.for file in efgdisplay.cc efgpanel.cc nfgpanel.cc
+ @${REINPLACE_CMD} -e '/#if/s: or : || :g' ${WRKSRC}/sources/gui/${file}
+.endfor
+
.include <bsd.port.mk>