aboutsummaryrefslogtreecommitdiffstats
path: root/math/gap/Makefile
diff options
context:
space:
mode:
authorkeith <keith@FreeBSD.org>2002-05-13 02:40:55 +0800
committerkeith <keith@FreeBSD.org>2002-05-13 02:40:55 +0800
commit2082000a52f715fca9e75df1af51996369f7201c (patch)
tree48c51c524ac325c03c32f0b27bc3f500f274038c /math/gap/Makefile
parent0a2a8eb928f0c33db3205d4c7de78002818f451e (diff)
downloadfreebsd-ports-gnome-2082000a52f715fca9e75df1af51996369f7201c.tar.gz
freebsd-ports-gnome-2082000a52f715fca9e75df1af51996369f7201c.tar.zst
freebsd-ports-gnome-2082000a52f715fca9e75df1af51996369f7201c.zip
Add GAP 4.3, a free system for computational discrete algebra.
Diffstat (limited to 'math/gap/Makefile')
-rw-r--r--math/gap/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
new file mode 100644
index 000000000000..f48593baf3ca
--- /dev/null
+++ b/math/gap/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gap
+# Date created: 28 Apr, 2002
+# Whom: keith@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gap
+PORTVERSION= 4.3
+CATEGORIES= math
+MASTER_SITES= ftp://ftp-gap.dcs.st-and.ac.uk/pub/gap/gap4/
+DISTFILES= gap4r3.tar.gz \
+ accpkg4r3.tar.gz deppkg4r3.tar.gz xtom4r3.tar.gz
+DIST_SUBDIR= gap
+
+MAINTAINER= keith@FreeBSD.org
+
+NO_CDROM= "Don't sell for profit."
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ (${MKDIR} ${WRKSRC}; \
+ cd ${WRKSRC}; \
+ ${TAR} xzf ${DISTDIR}/${DIST_SUBDIR}/gap4r3.tar.gz; \
+ ${TAR} xzf ${DISTDIR}/${DIST_SUBDIR}/xtom4r3.tar.gz ; \
+ cd ${WRKSRC}/gap4r3/pkg; \
+ ${TAR} xzf ${DISTDIR}/${DIST_SUBDIR}/accpkg4r3.tar.gz; \
+ ${TAR} xzf ${DISTDIR}/${DIST_SUBDIR}/deppkg4r3.tar.gz )
+
+do-configure:
+ (cd ${WRKSRC}/gap4r3; ./configure)
+
+do-build:
+ (cd ${WRKSRC}/gap4r3; make)
+
+do-install:
+ (${SED} -e "s:GAP_DIR=.*:GAP_DIR=${PREFIX}/lib/gap4r3:g" -e "s:GAP_PRG=.*:GAP_PRG=gap:g" ${WRKSRC}/gap4r3/bin/gap.sh > ${PREFIX}/bin/gap; \
+ ${CHMOD} 755 ${PREFIX}/bin/gap; )
+ @${MKDIR} ${PREFIX}/lib/gap4r3 ${PREFIX}/lib/gap4r3/bin
+ @${CP} ${WRKSRC}/gap4r3/bin/*/gap ${WRKSRC}/gap4r3/bin/*/gac ${PREFIX}/lib/gap4r3/bin
+.for subdir in doc etc grp lib pkg prim small trans tst
+ @${CP} -R ${WRKSRC}/gap4r3/${subdir} ${PREFIX}/lib/gap4r3/
+.endfor
+
+.include <bsd.port.post.mk>