aboutsummaryrefslogtreecommitdiffstats
path: root/math/gcalctool
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-07 08:38:15 +0800
committermarcus <marcus@FreeBSD.org>2004-01-07 08:38:15 +0800
commit6709dfea20a94c3883660d0d98f444e9fcab739b (patch)
tree92498ec6d57326af5c2109f773ebc600ff9f8fa6 /math/gcalctool
parente4c2d0e3c141951a3b104989e86a784c459acae1 (diff)
downloadfreebsd-ports-gnome-6709dfea20a94c3883660d0d98f444e9fcab739b.tar.gz
freebsd-ports-gnome-6709dfea20a94c3883660d0d98f444e9fcab739b.tar.zst
freebsd-ports-gnome-6709dfea20a94c3883660d0d98f444e9fcab739b.zip
Restore part of bland's patch. Certain locales actually don't have a
thousands separator (e.g. de_DE), and adding a default "," separator causes strange behavior. For more information on this ongoing saga, tune into: http://bugzilla.gnome.org/show_bug.cgi?id=130282
Diffstat (limited to 'math/gcalctool')
-rw-r--r--math/gcalctool/Makefile1
-rw-r--r--math/gcalctool/files/patch-gcalctool::get.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index a568a80f5b37..c857795bd522 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcalctool
PORTVERSION= 4.3.35
+PORTREVISION= 1
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/4.3
diff --git a/math/gcalctool/files/patch-gcalctool::get.c b/math/gcalctool/files/patch-gcalctool::get.c
new file mode 100644
index 000000000000..a3f0ed9ec1fe
--- /dev/null
+++ b/math/gcalctool/files/patch-gcalctool::get.c
@@ -0,0 +1,11 @@
+--- gcalctool/get.c.orig Tue Jan 6 19:18:44 2004
++++ gcalctool/get.c Tue Jan 6 19:19:01 2004
+@@ -234,7 +234,7 @@
+ tsep = g_locale_to_utf8(tsep, -1, NULL, NULL, NULL);
+ }
+
+- if (tsep == NULL || tsep[0] == '\0') {
++ if (tsep == NULL) {
+ return(",");
+ } else {
+ return(tsep);