aboutsummaryrefslogtreecommitdiffstats
path: root/math/ggobi
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-02-13 03:25:43 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-02-13 03:25:43 +0800
commit03fd13e6e32a437df1c08d0296782570d29c6258 (patch)
treea70267a860e8c7979a198944d8cc24b3ea69c25f /math/ggobi
parent4c804f4c8a61825c0466fe30696a5c791dfdd914 (diff)
downloadfreebsd-ports-gnome-03fd13e6e32a437df1c08d0296782570d29c6258.tar.gz
freebsd-ports-gnome-03fd13e6e32a437df1c08d0296782570d29c6258.tar.zst
freebsd-ports-gnome-03fd13e6e32a437df1c08d0296782570d29c6258.zip
GGobi is an open source visualization program for exploring high-dimensional
data. It provides highly dynamic and interactive graphics such as tours, as well as familiar graphics such as the scatterplot, barchart and parallel coordinates plots. Plots are interactive and linked with brushing and identification. WWW: http://www.ggobi.org/ PR: ports/143405 Submitted by: rhurlin
Diffstat (limited to 'math/ggobi')
-rw-r--r--math/ggobi/Makefile36
-rw-r--r--math/ggobi/distinfo3
-rw-r--r--math/ggobi/pkg-descr7
-rw-r--r--math/ggobi/pkg-plist135
4 files changed, 181 insertions, 0 deletions
diff --git a/math/ggobi/Makefile b/math/ggobi/Makefile
new file mode 100644
index 000000000000..801b238ce4ff
--- /dev/null
+++ b/math/ggobi/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: ggobi
+# Date created: 31 January 2010
+# Whom: rhurlin
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggobi
+PORTVERSION= 2.1.8
+CATEGORIES= math graphics
+MASTER_SITES= http://www.ggobi.org/downloads/
+
+MAINTAINER= rhurlin@gwdg.de
+COMMENT= Data visualization system
+
+USE_BZIP2= yes
+USE_GNOME= gtk20 libxml2 gnomehack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --with-all-plugins
+
+ALL_TARGET= all ggobirc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|ND_coord_i|ND_coord|' \
+ ${WRKSRC}/plugins/GraphLayout/graphviz.c
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/xdg/ggobi
+ ${INSTALL_DATA} ${WRKSRC}/ggobirc ${PREFIX}/etc/xdg/ggobi/ggobirc.sample
+ @if [ ! -f ${PREFIX}/etc/xdg/ggobi/ggobirc ]; then \
+ ${CP} -p ${PREFIX}/etc/xdg/ggobi/ggobirc.sample ${PREFIX}/etc/xdg/ggobi/ggobirc ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/math/ggobi/distinfo b/math/ggobi/distinfo
new file mode 100644
index 000000000000..303f97291811
--- /dev/null
+++ b/math/ggobi/distinfo
@@ -0,0 +1,3 @@
+MD5 (ggobi-2.1.8.tar.bz2) = 0b07adffcf4379e819b1a26e4cd60d7b
+SHA256 (ggobi-2.1.8.tar.bz2) = 2f814376d08a783628d2150d64cddda2e86b71f12847f1d51ba977197102fa8f
+SIZE (ggobi-2.1.8.tar.bz2) = 2531628
diff --git a/math/ggobi/pkg-descr b/math/ggobi/pkg-descr
new file mode 100644
index 000000000000..6973f911eb3a
--- /dev/null
+++ b/math/ggobi/pkg-descr
@@ -0,0 +1,7 @@
+GGobi is an open source visualization program for exploring high-dimensional
+data. It provides highly dynamic and interactive graphics such as tours, as
+well as familiar graphics such as the scatterplot, barchart and parallel
+coordinates plots. Plots are interactive and linked with brushing and
+identification.
+
+WWW: http://www.ggobi.org/
diff --git a/math/ggobi/pkg-plist b/math/ggobi/pkg-plist
new file mode 100644
index 000000000000..f97b99de9626
--- /dev/null
+++ b/math/ggobi/pkg-plist
@@ -0,0 +1,135 @@
+bin/ggobi
+include/ggobi/GGStructSizes.c
+include/ggobi/GGobiAPI.h
+include/ggobi/GGobiApp.h
+include/ggobi/GGobiEvents.h
+include/ggobi/barchartDisplay.h
+include/ggobi/brushing.h
+include/ggobi/colorscheme.h
+include/ggobi/config.h
+include/ggobi/cpanel.h
+include/ggobi/defines.h
+include/ggobi/display.h
+include/ggobi/display_tree.h
+include/ggobi/externs.h
+include/ggobi/fileio.h
+include/ggobi/ggobi-data.h
+include/ggobi/ggobi-intl.h
+include/ggobi/ggobi-renderer-cairo.h
+include/ggobi/ggobi-renderer-factory.h
+include/ggobi/ggobi-renderer.h
+include/ggobi/ggobi.h
+include/ggobi/ggobiClass.h
+include/ggobi/marshal.h
+include/ggobi/noop-toggle.h
+include/ggobi/parcoordsClass.h
+include/ggobi/plugin.h
+include/ggobi/print.h
+include/ggobi/read_csv.h
+include/ggobi/read_init.h
+include/ggobi/read_xml.h
+include/ggobi/scatmatClass.h
+include/ggobi/scatterplotClass.h
+include/ggobi/splash.h
+include/ggobi/splot.h
+include/ggobi/testEvents.h
+include/ggobi/tour.h
+include/ggobi/tour1d_pp.h
+include/ggobi/tour2d_pp.h
+include/ggobi/tour_pp.h
+include/ggobi/tsPlot.h
+include/ggobi/tsdisplay.h
+include/ggobi/types.h
+include/ggobi/vars.h
+include/ggobi/varseldata.h
+include/ggobi/vartable.h
+include/ggobi/write_xml.h
+include/ggobi/writedata.h
+lib/libggobi.la
+lib/libggobi.so
+lib/libggobi.so.0
+libdata/pkgconfig/ggobi.pc
+share/applications/ggobi.desktop
+%%DATADIR%%/data/Shipman.csv
+%%DATADIR%%/data/Shipman.xml
+%%DATADIR%%/data/adhoc.xml
+%%DATADIR%%/data/algal-bloom.xml
+%%DATADIR%%/data/buckyball.xml
+%%DATADIR%%/data/cube6.xml
+%%DATADIR%%/data/eies.xml
+%%DATADIR%%/data/flea.csv
+%%DATADIR%%/data/flea.xml
+%%DATADIR%%/data/laser.csv
+%%DATADIR%%/data/laser.xml
+%%DATADIR%%/data/morsecodes.xml
+%%DATADIR%%/data/olive.csv
+%%DATADIR%%/data/olive.xml
+%%DATADIR%%/data/perm4.xml
+%%DATADIR%%/data/perm5.xml
+%%DATADIR%%/data/pigs.xml
+%%DATADIR%%/data/places.csv
+%%DATADIR%%/data/places.xml
+%%DATADIR%%/data/prim7.xml
+%%DATADIR%%/data/ratcns.csv
+%%DATADIR%%/data/ratcns.xml
+%%DATADIR%%/data/river.xml
+%%DATADIR%%/data/roos.csv
+%%DATADIR%%/data/roos.xml
+%%DATADIR%%/data/sarsHK.xml
+%%DATADIR%%/data/sat.csv
+%%DATADIR%%/data/sat.xml
+%%DATADIR%%/data/sleep.csv
+%%DATADIR%%/data/sleep.xml
+%%DATADIR%%/data/snetwork.xml
+%%DATADIR%%/data/stdColorMap.xml
+%%DATADIR%%/data/tao-nomiss.xml
+%%DATADIR%%/data/tao.csv
+%%DATADIR%%/data/tao.xml
+%%DATADIR%%/data/tips.csv
+%%DATADIR%%/data/tips.xml
+%%DATADIR%%/data/tmin.csv
+%%DATADIR%%/data/tmin.xml
+%%DATADIR%%/data/tmin1.csv
+%%DATADIR%%/data/tmin1.xml
+%%DATADIR%%/data/tmin2.xml
+%%DATADIR%%/data/tmin3.xml
+%%DATADIR%%/data/tmin4.xml
+%%DATADIR%%/plugins/DataViewer/plugin.la
+%%DATADIR%%/plugins/DataViewer/plugin.so
+%%DATADIR%%/plugins/DataViewer/plugin.so.0
+%%DATADIR%%/plugins/DescribeDisplay/plugin.la
+%%DATADIR%%/plugins/DescribeDisplay/plugin.so
+%%DATADIR%%/plugins/DescribeDisplay/plugin.so.0
+%%DATADIR%%/plugins/GraphAction/plugin.la
+%%DATADIR%%/plugins/GraphAction/plugin.so
+%%DATADIR%%/plugins/GraphAction/plugin.so.0
+%%DATADIR%%/plugins/GraphLayout/plugin.la
+%%DATADIR%%/plugins/GraphLayout/plugin.so
+%%DATADIR%%/plugins/GraphLayout/plugin.so.0
+%%DATADIR%%/plugins/VarCloud/plugin.la
+%%DATADIR%%/plugins/VarCloud/plugin.so
+%%DATADIR%%/plugins/VarCloud/plugin.so.0
+%%DATADIR%%/plugins/ggvis/plugin.la
+%%DATADIR%%/plugins/ggvis/plugin.so
+%%DATADIR%%/plugins/ggvis/plugin.so.0
+%%DATADIR%%/share/colorschemes.xml
+share/pixmaps/ggobi.png
+@dirrm %%DATADIR%%/share
+@dirrm %%DATADIR%%/plugins/ggvis
+@dirrm %%DATADIR%%/plugins/VarCloud
+@dirrm %%DATADIR%%/plugins/GraphLayout
+@dirrm %%DATADIR%%/plugins/GraphAction
+@dirrm %%DATADIR%%/plugins/DescribeDisplay
+@dirrm %%DATADIR%%/plugins/DataViewer
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrm share/applications
+@dirrmtry libdata/pkgconfig
+@dirrm include/ggobi
+@unexec if cmp -s %D/etc/xdg/ggobi/ggobirc.sample %D/etc/xdg/ggobi/ggobirc; then rm -f %D/etc/xdg/ggobi/ggobirc; fi
+etc/xdg/ggobi/ggobirc.sample
+@exec if [ ! -f %B/ggobirc ]; then cp -p %D/%F %B/ggobirc; fi
+@dirrmtry share/applications
+@dirrmtry etc/xdg/ggobi
+@dirrmtry etc/xdg