aboutsummaryrefslogtreecommitdiffstats
path: root/math/glm
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2013-03-11 20:42:33 +0800
committerdemon <demon@FreeBSD.org>2013-03-11 20:42:33 +0800
commitf2af2513084752f5df3a7067bc49fe6dad03c281 (patch)
tree3cba754c73389810f61f7e178ec272fff3b85aca /math/glm
parent554a77b015082d547caf1970198819fb65d0c8ff (diff)
downloadfreebsd-ports-gnome-f2af2513084752f5df3a7067bc49fe6dad03c281.tar.gz
freebsd-ports-gnome-f2af2513084752f5df3a7067bc49fe6dad03c281.tar.zst
freebsd-ports-gnome-f2af2513084752f5df3a7067bc49fe6dad03c281.zip
Update to version 0.9.4.2.
Diffstat (limited to 'math/glm')
-rw-r--r--math/glm/Makefile2
-rw-r--r--math/glm/distinfo4
-rw-r--r--math/glm/pkg-plist14
3 files changed, 11 insertions, 9 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index d484cfbb21a2..04f23c0209c2 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glm
-PORTVERSION= 0.9.3.4
+PORTVERSION= 0.9.4.2
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ogl-math/${PORTNAME}-${PORTVERSION}
diff --git a/math/glm/distinfo b/math/glm/distinfo
index 01913796c99b..aa6a3b1a7b58 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glm-0.9.3.4.zip) = 0646b29718cf3ad2ee9c4c9dcb2d5b1d9b483fc0b71764e93b369934203d90ce
-SIZE (glm-0.9.3.4.zip) = 6371127
+SHA256 (glm-0.9.4.2.zip) = 40a9aa9d2ec6ec45aabafbbc29f568dbe73b8c0fb169b17a1684e53667c3ee98
+SIZE (glm-0.9.4.2.zip) = 4500361
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index c314c6699d33..7836794a9de7 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -77,6 +77,10 @@ include/glm/core/type_vec4.hpp
include/glm/core/type_vec4.inl
include/glm/ext.hpp
include/glm/glm.hpp
+include/glm/gtc/constants.hpp
+include/glm/gtc/constants.inl
+include/glm/gtc/epsilon.hpp
+include/glm/gtc/epsilon.inl
include/glm/gtc/half_float.hpp
include/glm/gtc/half_float.inl
include/glm/gtc/matrix_access.hpp
@@ -92,12 +96,16 @@ include/glm/gtc/quaternion.hpp
include/glm/gtc/quaternion.inl
include/glm/gtc/random.hpp
include/glm/gtc/random.inl
+include/glm/gtc/reciprocal.hpp
+include/glm/gtc/reciprocal.inl
include/glm/gtc/swizzle.hpp
include/glm/gtc/swizzle.inl
include/glm/gtc/type_precision.hpp
include/glm/gtc/type_precision.inl
include/glm/gtc/type_ptr.hpp
include/glm/gtc/type_ptr.inl
+include/glm/gtc/ulp.hpp
+include/glm/gtc/ulp.inl
include/glm/gtx/associated_min_max.hpp
include/glm/gtx/associated_min_max.inl
include/glm/gtx/bit.hpp
@@ -115,9 +123,7 @@ include/glm/gtx/compatibility.inl
include/glm/gtx/component_wise.hpp
include/glm/gtx/component_wise.inl
include/glm/gtx/constants.hpp
-include/glm/gtx/constants.inl
include/glm/gtx/epsilon.hpp
-include/glm/gtx/epsilon.inl
include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
include/glm/gtx/extend.hpp
@@ -159,7 +165,6 @@ include/glm/gtx/mixed_product.inl
include/glm/gtx/multiple.hpp
include/glm/gtx/multiple.inl
include/glm/gtx/noise.hpp
-include/glm/gtx/noise.inl
include/glm/gtx/norm.hpp
include/glm/gtx/norm.inl
include/glm/gtx/normal.hpp
@@ -183,11 +188,9 @@ include/glm/gtx/projection.inl
include/glm/gtx/quaternion.hpp
include/glm/gtx/quaternion.inl
include/glm/gtx/random.hpp
-include/glm/gtx/random.inl
include/glm/gtx/raw_data.hpp
include/glm/gtx/raw_data.inl
include/glm/gtx/reciprocal.hpp
-include/glm/gtx/reciprocal.inl
include/glm/gtx/rotate_vector.hpp
include/glm/gtx/rotate_vector.inl
include/glm/gtx/simd_mat4.hpp
@@ -205,7 +208,6 @@ include/glm/gtx/transform.inl
include/glm/gtx/transform2.hpp
include/glm/gtx/transform2.inl
include/glm/gtx/ulp.hpp
-include/glm/gtx/ulp.inl
include/glm/gtx/unsigned_int.hpp
include/glm/gtx/unsigned_int.inl
include/glm/gtx/vec1.hpp