aboutsummaryrefslogtreecommitdiffstats
path: root/math/glpk
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2007-12-12 22:12:43 +0800
committerdemon <demon@FreeBSD.org>2007-12-12 22:12:43 +0800
commit0a8c3bdc9a91d91c90698a8a43b9efb07c08b561 (patch)
tree88ced7db5e067628111409004b734e5fd1fb1d71 /math/glpk
parente8ec786e56964cf9b698c3557a08e2329ff19e13 (diff)
downloadfreebsd-ports-gnome-0a8c3bdc9a91d91c90698a8a43b9efb07c08b561.tar.gz
freebsd-ports-gnome-0a8c3bdc9a91d91c90698a8a43b9efb07c08b561.tar.zst
freebsd-ports-gnome-0a8c3bdc9a91d91c90698a8a43b9efb07c08b561.zip
- Update to version 4.24.
- include headers required for building gmpl support in math/clp - remover -fPIC hack for amd64 which doesn't seem necessary anymore. PR: 118265 Submitted by: "Pedro F. Giffuni" <giffunip@tutopia.com>
Diffstat (limited to 'math/glpk')
-rw-r--r--math/glpk/Makefile18
-rw-r--r--math/glpk/distinfo6
-rw-r--r--math/glpk/pkg-plist9
3 files changed, 21 insertions, 12 deletions
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index 2608ab918c3e..289c28bd8533 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glpk
-PORTVERSION= 4.21
+PORTVERSION= 4.24
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glpk
@@ -23,11 +23,19 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
CFLAGS+= -trigraphs
+GMPL_H= glpavl.h glpdmp.h glplib.h glpmpl.h glprng.h glpstd.h
+GMPLDIR= ${LOCALBASE}/include/gmpl
+
.if !defined(NOPORTDOCS)
PORTDOCS= bench.txt bench1.txt glpk.ps glpk_faq.txt gmpl.ps opb.txt
.endif
post-install:
+ @${MKDIR} ${GMPLDIR}
+ for incfile in ${GMPL_H} ; do \
+ ${INSTALL_DATA} ${WRKSRC}/include/$${incfile} ${GMPLDIR} ; \
+ done
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
for docfile in ${PORTDOCS} ; do \
@@ -35,10 +43,4 @@ post-install:
done
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CFLAGS+= -fPIC
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/glpk/distinfo b/math/glpk/distinfo
index cb31eeb9988e..99025f7e99af 100644
--- a/math/glpk/distinfo
+++ b/math/glpk/distinfo
@@ -1,3 +1,3 @@
-MD5 (glpk-4.21.tar.gz) = a41df71415c97fc5c541d19547ced10a
-SHA256 (glpk-4.21.tar.gz) = 3be04106ef18b1f92af9fe7936ecb675a04cabab72ff65e1a03bf2205d99d549
-SIZE (glpk-4.21.tar.gz) = 1413712
+MD5 (glpk-4.24.tar.gz) = 765dcecc20dc6b80362e65c755f41976
+SHA256 (glpk-4.24.tar.gz) = 23326c9dd21762159b6fa946e41e0e95d233c6e9f9a69134ef10e3541cd516c9
+SIZE (glpk-4.24.tar.gz) = 1449575
diff --git a/math/glpk/pkg-plist b/math/glpk/pkg-plist
index 9f0ab524b042..68d08025673e 100644
--- a/math/glpk/pkg-plist
+++ b/math/glpk/pkg-plist
@@ -1,6 +1,13 @@
bin/glpsol
include/glpk.h
+include/gmpl/glpavl.h
+include/gmpl/glpdmp.h
+include/gmpl/glplib.h
+include/gmpl/glpmpl.h
+include/gmpl/glprng.h
+include/gmpl/glpstd.h
+@dirrm include/gmpl
lib/libglpk.a
lib/libglpk.la
lib/libglpk.so
-lib/libglpk.so.6
+lib/libglpk.so.9